2 Replies Latest reply on Jan 4, 2018 11:58 AM by amigos da pintadinha

    Duik bones created in wrong locations

    Neo Conker

      I created my character in illustrator with a bunch of different layers (one for arms, different ones for all the hands etc.


      I brought it in after effects, importing all the after effects vector layers (making sure continuously rasterize is on).


      It seems with Duik I have to create bones for each individual layer and cant use one bone for multiple pins (which i'm not used do since i'm quite experienced in 3D rigging, but not 2D) but when i create a pin on say the arm layer, i put 3 pins (shoulder, elbow, wrist), then rename the pins correctly, and when i click on a pin and create a bone it creates the bone with the correct name, and the bone is connected to the arm, however it is places really really far away, sometimes even out of frame from the puppet pin. The arm illustrator layer is not parented to anything either.


      I tried just having a regular shape layer with a pin and Duik will create the bone just fine, just not on any of the illustrator layers. Nothing is named the name or anything like that, does anyone know why this is?



        • 1. Re: Duik bones created in wrong locations
          Mylenium Most Valuable Participant

          Ah, and there's the culprit:

          (making sure continuously rasterize is on).

          That's nonsense. The Puppet tool is still a conventional distortion effect that operates on pixels, not the native vector contours. You are making a mess of the coordinates, hence the expressions used by DUIK cannot work correctly. I suggest you read the help on the subject on when to use CR and when not.



          • 2. Re: Duik bones created in wrong locations
            amigos da pintadinha

            Hello Friend

            This is because you left an active option, which is to vectorize the layers because with this option activates the puppet does not work correctly as soon as the dimensions used by duik will go out wrongly, it is only disable the vector option and do it again that will be all right.


            Friends of Pintadinha