8 Replies Latest reply on Aug 18, 2017 4:01 AM by markofo

    CF12(2016) - issue with IIS connectors not displaying, can't remove.

    phem0r Level 1

      Hello

       

      I've been installing ColdFusion 2016 on a Windows 2012 R2 server with IIS 8.5 and as part of the installation i selected for CF to configure all IIS websites. I probably shouldn't of done this as i had no sites added in IIS apart from the normal 'default website'

       

      I setup my website and then launch wsconfig.exe to configure IIS for my new website but according to wsconfig, IIS isn't configured as it is blank in the list of configured sites but then if you hit 'Add', am i presented with the error 'All the IIS sites are already configured by some other version of ColdFusion'

      1.PNG

       

      I've been googling for some time and I've tried cf11 guides to manually remove the connector as it's not displaying one for me but the items to be manually removed don't exist. For instance there is no numbered folder in C:\ColdFusion2016\config\wsconfig. There is only a dll and log file. I've been through all of the sites within IIS to manually remove the various CF isapi filters, isapi and cgi restrictions, mime types and handler mappings but again they don't exist.

       

      I cannot add a new connector because the Ok button is greyed out within the tool

      2.PNG

       

      Another suggestion was to make sure the latest version of Vistual studio C++ redistribution was installed, i've done that and still the same issue.

       

      Any suggestions/ideas would be greatly appreciated!

       

      Thanks,

      Allan