3 Replies Latest reply on Sep 26, 2016 1:48 PM by rechmbrs

    Photoshop Elements 14 needs more recent ACR

    rechmbrs Level 1

      PSE 14 needs a more recent ACR to process DNG files from Pentax K1 using PixelShift mode.   Is the users only choice to wait for PSE 15?

       

      Not a good situation for users.

       

      RONC

        • 1. Re: Photoshop Elements 14 needs more recent ACR
          JimHess Adobe Community Professional & MVP

          That camera was first supported in Camera Raw 9.5.1 which is compatible with Photoshop Elements 14. I don't know anything about support for pixel shift. I haven't followed that technology.

          • 2. Re: Photoshop Elements 14 needs more recent ACR
            Jeff Arola Adobe Community Professional

            Actually adobe does this every year.

             

            About 2 or 3 months before a new version of photoshop elements comes out, adobe stops updating photoshop elements's camera raw plugin, no matter how many versions of acr appear before the next version of pse.

             

            As far i can tell and according to adobe, acr 9.5 is the newest version adobe provides for pse 14 if one uses Help>Updates, though pse 14 can use the newest 9.7 version of the camera raw plugin if one were to install it manually.

             

            Don't know if there will be a pse 15, but if there is and history is any indication, pse 15 should be out by the end of September or early October.

             

            In other words pse 15 could be out any day now.

            • 3. Re: Photoshop Elements 14 needs more recent ACR
              rechmbrs Level 1

              PSE 14 is limited internally to ACR 9.5.0.  Manual update to ACR 9.5.1 and

              up is rejected by PSE.

               

              Looks like they have to wait for PSE 15 if there is one.

               

              RONC