3 Replies Latest reply on Oct 21, 2016 2:59 PM by jmartinezpena

    Cannot build Android: buildToolsVersion is not specified.

    jmartinezpena Level 1

      I've been working with build.phonegap.com with good results. However, the same code I used yesterday is not working today (I clicked Rebuild)

      It builds successfully for iOS and Windows, but not for Android. Here is the main part of the log:


      FAILURE: Build failed with an exception.


      * Where:

      Script '/project/CordovaLib/cordova.gradle' line: 128


      * What went wrong:

      A problem occurred evaluating root project 'project'.

      > No match found


      * Try:

      Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.




      Total time: 0.998 secs

      Error: /project/gradlew: Command failed with exit code 1 Error output:

      Failed to notify ProjectEvaluationListener.afterEvaluate(), but primary configuration failure takes precedence.

      java.lang.IllegalStateException: buildToolsVersion is not specified.

        at com.google.common.base.Preconditions.checkState(Preconditions.java:176)