9 Replies Latest reply on Oct 10, 2016 6:58 AM by MyQuest

    Issues with building my Android app due to missing Android depdendency

    MyQuest

      Hi,

      The Android build of my application fails with error  - "Could not find support-v4.jar (com.android.support:support-v4:24.1.1)."

      The build log also states which plugin it is - intercom.

      The thing is, that unlike other case I have seen on the form, I did pin the version to 3.0.8 and was able to build just fine with that version. And now I can't...

      And yes, it makes sense that the intercom guys did something wrong which caused this, but they don't know what's wrong.

      And I don't have log of a successful compilation to know which Android version was used then.

      Can anyone help me? Best choice would be to add the Android 24.1.1 library.

       

      Thanks,

      Oded

       

      Full build log: (https://build.phonegap.com/apps/2018524/logs/android/build/ )

       

      Build Date: 2016-09-28 08:19:42 +0000

      --------------------------------------------------------------------------------

      PLUGIN OUTPUT

      --------------------------------------------------------------------------------

      Installing "org.apache.cordova.device" at "0.3.0" for android

      Fetching plugin "cordova-plugin-intercom@3.0.8" via npm

      Installing "cordova-plugin-intercom" at "3.0.8" for android

      Notice: org.apache.cordova.inappbrowser has been automatically converted to cordova-plugin-inappbrowser and fetched from npm. This is due to our old plugins registry shutting down.

      Fetching plugin "cordova-plugin-inappbrowser@1.4.0" via npm

      Installing "cordova-plugin-inappbrowser" at "1.4.0" for android

      Fetching plugin "cordova-plugin-network-information@1.2.1" via npm

      Installing "cordova-plugin-network-information" at "1.2.1" for android

      Fetching plugin "cordova-plugin-splashscreen@3.2.2" via npm

      Installing "cordova-plugin-splashscreen" at "3.2.2" for android

      Fetching plugin "cordova-plugin-statusbar@2.1.3" via npm

      Installing "cordova-plugin-statusbar" at "2.1.3" for android

      Fetching plugin "ionic-plugin-keyboard@2.2.0" via npm

      Installing "ionic-plugin-keyboard" at "2.2.0" for android

      Fetching plugin "cordova-plugin-whitelist@1.2.2" via npm

      Installing "cordova-plugin-whitelist" at "1.2.2" for android

       

        This plugin is only applicable for versions of cordova-android greater than 4.0. If you have a previous platform version, you do *not* need this plugin since the whitelist will be built in.

      --------------------------------------------------------------------------------

      COMPILE OUTPUT

      --------------------------------------------------------------------------------

      Configuration on demand is an incubating feature.

      Incremental java compilation is an incubating feature.

      Download https://jcenter.bintray.com/io/intercom/android/intercom-sdk/3.0.3/intercom-sdk-3.0.3.pom

      Download https://jcenter.bintray.com/io/intercom/android/intercom-sdk-base/3.0.3/intercom-sdk-base- 3.0.3.pom

      Download https://jcenter.bintray.com/io/intercom/android/intercom-sdk-gcm/3.0.3/intercom-sdk-gcm-3. 0.3.pom

       

      FAILURE: Build failed with an exception.

       

      * What went wrong:

      A problem occurred configuring root project 'project'.

      > Could not find support-v4.jar (com.android.support:support-v4:24.1.1).

        Searched in the following locations:

        https://jcenter.bintray.com/com/android/support/support-v4/24.1.1/support-v4-24.1.1.jar

       

      * Try:

      Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

       

      BUILD FAILED

       

      Total time: 10.213 secs

      Error: /project/gradlew: Command failed with exit code 1 Error output:

      FAILURE: Build failed with an exception.

       

      * What went wrong:

      A problem occurred configuring root project 'project'.

      > Could not find support-v4.jar (com.android.support:support-v4:24.1.1).

        Searched in the following locations:

        https://jcenter.bintray.com/com/android/support/support-v4/24.1.1/support-v4-24.1.1.jar

       

      * Try:

      Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

        at ChildProcess.whenDone (/project/cordova/node_modules/cordova-common/src/superspawn.js:169:23)

        at emitTwo (events.js:106:13)

        at ChildProcess.emit (events.js:191:7)

        at maybeClose (internal/child_process.js:877:16)

        at Process.ChildProcess._handle.onexit (internal/child_process.js:226:5)