5 Replies Latest reply on Oct 6, 2016 1:49 AM by weckmann_adobe

    Phonegap CLI 6.3.0: App build fails for windows - plugin-push-1.8.2

    weckmann_adobe

      Hi,

       

      we are using Phonegap CLI 6.3.0 and facing following error for the windows build (via build.phonegap.com)

       

      Error - Plugin error (you probably need to remove plugin files from your app): Fetching plugin "phonegap-plugin-push@1.8.2" via npm Installing "phonegap-plugin-push" at "1.8.2" for windows Updating appxmanifests with ToastCapable=true... Failed to install 'phonegap-plugin-push':Error: Cannot find module 'C:\cygwin\tmp\gimlet\<ID>\project\platforms\windows\cordova\lib\AppxManifest' at Function.Module._resolveFilename (module.js:337:15) at Function.Module._load (module.js:287:25) at Module.require (module.js:366:17) at require (module.js:385:17) at module.exports (C:\cygwin\tmp\gimlet\<ID>\project\cordova\plugins\phonegap-plugin-push\hooks\windows\setToastCapable.js:5:24) at runScriptViaModuleLoader (C:\Users\Administrator\AppData\Roaming\npm\node_modules\pgb-plugman\node_modules\pgb-cor dova-lib\src\hooks\HooksRunner.js:187:18) at runScript (C:\Users\Administrator\AppData\Roaming\npm\node_modules\pgb-plugman\node_modules\pgb-cor dova-lib\src\hooks\HooksRunner.js:165:16) at C:\Users\Administrator\AppData\Roaming\npm\node_modules\pgb-plugman\node_modules\pgb-cord ova-lib\src\hooks\HooksRunner.js:133:20 at _fulfilled (C:\Users\Administrator\AppData\Roaming\npm\node_modules\pgb-plugman\node_modules\q\q.js: 787:54) at self.promiseDispatch.done (C:\Users\Administrator\AppData\Roaming\npm\node_modules\pgb-plugman\node_modules\q\q.js: 816:30) Cannot find module 'C:\cygwin\tmp\gimlet\<ID>\project\platforms\windows\cordova\lib\AppxManifest' - You can fix this ...

       

      Does anybody know what`s wrong? Maybe something is missing in the config?

       

      Thanks in advance,