5 Replies Latest reply on Oct 7, 2016 1:31 PM by Dave LaRonde

    What is the oldest version of After Effects that will work on a Yosemite 10.10.5?

    RobinHF

           Question 1:  What is the oldest version of After Effects that will work on a Mac with Yosemite 10.10.5?

       

      I am currently working with CS5.5 on my mac which has Yosemite 10.10.5 loaded. My contract work requires heavy use of the other programs, and they have served me well so far... but recently I have started learning After Effects. Every time I choose the color picker it crashes. I have read your posts suggesting I change the preference to "System Color Picker", and it seems to work for a few minutes before it crashes again... but it is a bit maddening.

       

       

           Question 2:  Has there ever been a better fix?

       

      I know these are old versions, but I work for myself, and as I said, most of my work is done with PS, Ai, ID... etc and I am loathe to drop $$$ monthly fees just to learn something I might or might not be using right away. I have considered purchasing a later box version of After Effects just so I can learn the program, but don't want to get something that will also not work. Now, Apple is suggesting I upgrade to Sierra... which might create even more of a problem.

       

           Question 3:  What is the oldest version of After Effects that will work on a Mac with Sierra loaded?

       

           Question 4:  Is there somewhere that sells the latest previous version of the After Effects before CC? Thanks for your feedback.