7 Replies Latest reply on Jul 23, 2009 5:44 AM by RoboWizard

    Can't get audio to record

    BasementJack Level 1
      When I try and record a screen cast, I get no audio - I get a warning "Adobe Captivate must establish audio input and recording sensitivity levels to create the best possible audio quality. Do you want to continue testing audio levels?
      I click Yes Nothing happens.
      I click the red record button again, and it starts recording, but I have no audio.

      I am running Vista x64. Captivate 4 build 1596 with the modified NSAudio.dll of size 536 K (that was mentioned in another post on the forum, but didn't fix my issue.

      In my Audio settings screen , there is a 'calibrate audio' button - clicking it does nothing.
      Please help!

      My audio device is an M-Audio sound card which does show up in the drop down as a source.


        • 1. Re: Can't get audio to record
          retro74 Level 1
          WELCOME to the all volunteer forum.
          This is a known problem with some Vista instals and some hardware configurations. Adobe has a pre-patch driver for this: Posted from another post... here ya go:

          Close Captivate 4 if it is open.
          Download the file kept at
          Captivate 4 NSAudio.DLL Patch

          Go to your Captivate 4 install folder (ex: C:\Program Files\Adobe\Adobe Cativate 4)
          Rename nsaudio.dll as nsaudio.dll.bak or anything which doesn't have a dll extension
          Copy the file from step 2 to Captivate 4 install folder
          rename it as nsaudio.dll
          Start Captivate 4
          Try to play the audio /use USB - it should go fine

          Hope this helps

          Joe C.
          • 2. Re: Can't get audio to record
            Captiv8r Adobe Community Professional & MVP
            Hey there Joe

            Hopefully the nsaudio.dll trick will work for BasementJack.

            However, there is other information that may be pertinent too. I had awful audio issues myself and the nsaudio.dll hokey pokey didn't solve my own issues. What finally did solve them was to follow what is outlined in the blog post below.

            Click here to read the blog post

            Cheers... Rick
            • 3. Can't get audio to record
              BasementJack Level 1
              Thanks guys, I really appreciate your replies.

              Joe, I already had the updated NSAudio.dll, but I still appreciate your mentioning it!

              Rick, I think your solution was the closest - just minutes before I recieved an email from Suresh J. from adobe about the same issue, he suggested to do a regsvr32 against the new dll, which I did and that resolved my issue. Rick - I looked at your post and noticed something towards the end that mentioned registering a DLL - so I'm sure that would have fixed it too!

              As a side note, I haven't seen this mentioned, but I ran into it so I'll mention it here -
              when I did the regsvr32 nsaudio.dll, I initially got an error x80070005 - A quick google search showed that as a permissions error - and reminded me to run the command prompt in admin mode on vista x64.
              after that I was able to register the DLL and I now have sound!

              Its back to work learning this software now!

              Thanks again to Joe and Rick from the forum and also to Suresh J from Adobe (QE manager for captivate - who answered my first email on a SATURDAY! - Great service!)
              • 4. Re: Can't get audio to record
                retro74 Level 1
                In general, modern DLL's are self registering, but there is an exception for Vista-64. The security features in Vista-64 are strict and quite different that regular Vista. For example, in regular Vista you can try to install a program and you will get a message about granting rights to allow the install. But you can do it.

                In Vista-64 you must have the highest rights to install things and it appears that the NSAudio.dll is not going to self-register without explicit Admin rights. Looks like you found the issue. So far I have had good luck with installing NSAudio to get the recording to work, but the sound quality has been bad, muddy, muffled, broken up at times and generally not acceptable on either of my machines (XP and Vista Home premium with tons of drive space and tons of RAM). They tell me that they are working on the sound quality issues and I am [personally] hopeing for a patch to resolve the sound quality issues that I am experiencing.


                Glad you got this working in Vista-64.

                Joe C.
                • 5. Re: Can't get audio to record
                  BasementJack Level 1
                  Retro Joe,

                  I see what you mean about the stuttering. After reading your post, I thought I should try a real life recording and after about 3/4 of it the sound started to skip.

                  I tried a second time with some different settings and seemed to have better luck.

                  I used 128kbps, 44.1khz (which matches what my m-audio device is set to)
                  Also in windows vista, I noticed on the devices advanced tab the option to record 16 or 24 bits so I have that set to 16 now.

                  Probably most important, I set 'encoding speed' to the lowest number (the text says increased speed = lower quality so I went the other way)

                  I recorded a short test video with sound and it seemed ok.

                  More testing is needed, but I thought I'd post that in case you hadn't tried that.

                  my machine is a 3.6ghz dual core (intel E8400) 8gb ram, vista x64 ultimate
                  (Machine speed could be a factor on how low you can go)
                  • 6. Re: Can't get audio to record
                    sarah1765

                    I am having the same problems and the same error code and when I try your solution it does not work no matter what I do.  I need help asap!

                    • 7. Re: Can't get audio to record
                      RoboWizard Level 4

                      Hi there

                       

                      You probably need to contact Adobe Support if you need help right away. Especially seeing as how the things mentioned in this thread failed to help solve your issue.

                       

                      Cheers... Rick

                       

                       

                      Helpful and Handy Links