2 Replies Latest reply on Oct 18, 2016 3:30 PM by testec78498947

    Plugin inappbrowser error IOS build

    testec78498947

      Hello everyone,

       

      We have build an iPA file using Phonegap build site. but it is returning me an error in a plugin "inaapbrowser"

       

      Error - Plugin (or a specific plugin version) not found in external repo: cordova-plugin-inappbrowser@1.5.1-dev": Fetching plugin "cordova-plugin-inappbrowser@1.5.1-dev" via npm Failed to fetch plugin cordova-plugin-inappbrowser

       

      Build Date: 2016-10-11 12:39:49 -0700
      --------------------------------------------------------------------------------
      PLUGIN OUTPUT
      --------------------------------------------------------------------------------
      Fetching plugin "cordova-plugin-device@~1.1.2" via npm
      Installing "cordova-plugin-device" at "1.1.3" for ios
      Fetching plugin "cordova-plugin-console@~1.0.3" via npm
      Installing "cordova-plugin-console" at "1.0.4" for ios
      Fetching plugin "cordova-plugin-whitelist@~1.2.2" via npm
      Installing "cordova-plugin-whitelist" at "1.2.2" for ios
      Fetching plugin "cordova-plugin-splashscreen@~3.2.2" via npm
      Installing "cordova-plugin-splashscreen" at "3.2.2" for ios
      Fetching plugin "cordova-plugin-statusbar@~2.1.3" via npm
      Installing "cordova-plugin-statusbar" at "2.1.3" for ios
      Fetching plugin "ionic-plugin-keyboard@~2.2.1" via npm
      Installing "ionic-plugin-keyboard" at "2.2.1" for ios
      Fetching plugin "cordova-plugin-file@4.2.0" via npm
      Installing "cordova-plugin-file" at "4.2.0" for ios
      Fetching plugin "cordova-plugin-compat" via npm
      Installing "cordova-plugin-compat" at "1.0.0" for ios
      
      The Android Persistent storage location now defaults to "Internal". Please check this plugins README to see if you application needs any changes in its config.xml.
      
      If this is a new application no changes are required.
      
      If this is an update to an existing application that did not specify an "AndroidPersistentFileLocation" you may need to add:
      
        "<preference name="AndroidPersistentFileLocation" value="Compatibility" />"
      
      to config.xml in order for the application to find previously stored files.
      Fetching plugin "cordova-plugin-network-information@1.2.1" via npm
      Installing "cordova-plugin-network-information" at "1.2.1" for ios
      Fetching plugin "cordova-plugin-image-picker@1.1.1" via npm
      Installing "cordova-plugin-image-picker" at "1.1.1" for ios
      Plugin "cordova-plugin-compat" already installed on ios. Making it top-level.
      Fetching plugin "cordova-plugin-camera@2.2.0" via npm
      Installing "cordova-plugin-camera" at "2.2.0" for ios
      Dependent plugin "cordova-plugin-compat" already installed on ios.
      Fetching plugin "cordova-plugin-media-capture@1.3.0" via npm
      Installing "cordova-plugin-media-capture" at "1.3.0" for ios
      Dependent plugin "cordova-plugin-file" already installed on ios.
      Dependent plugin "cordova-plugin-compat" already installed on ios.
      Fetching plugin "cordova-plugin-geolocation@2.2.0" via npm
      Installing "cordova-plugin-geolocation" at "2.2.0" for ios
      Dependent plugin "cordova-plugin-compat" already installed on ios.
      Fetching plugin "cordova-plugin-globalization@1.0.3" via npm
      Installing "cordova-plugin-globalization" at "1.0.3" for ios
      "plugman install --platform ios --project /project --plugin cordova-plugin-inappbrowser@1.5.1-dev": Fetching plugin "cordova-plugin-inappbrowser@1.5.1-dev" via npm
      Failed to fetch plugin cordova-plugin-inappbrowser@1.5.1-dev via registry.
      Probably this is either a connection problem, or plugin spec is incorrect.
      Check your connection and plugin name/version/URL.
      Error: version not found: cordova-plugin-inappbrowser@1.5.1-dev