8 Replies Latest reply on Oct 14, 2016 3:25 AM by Just Shoot Me

    Previews (pictures) not showing up in library module

    emick600 Level 1

      When I open up LR5, and select a folder, in this case my "my portfolio" folder, all the information is there (number of photos, folder name, develop settings, etc.), but the actual photo preview is missing. All I see is a bunch of gray squares. I have already set my display profile to sRGB, updated my HD graphics driver, and tried selecting "build 1:1 previews" in the library drop down menu. Nothing seems to work. Any help to keep me from quitting photography all together would be greatly appreciated. My computer has updated a couple of times since the last time I opened LR, not sure if that has anything to do with it or not. Thank you in advance.

        • 1. Re: Previews (pictures) not showing up in library module
          emick600 Level 1

          Also, I apologize if this has been covered already. If there is a link to some discussion, that would be great.

          • 3. Re: Previews (pictures) not showing up in library module
            Per Berntsen Adobe Community Professional

            Try deleting the preview cache folder.

            Close Lightroom, then use Windows Explorer/Mac Finder, and navigate to the folder that contains the Lightroom catalog.

            Delete the folder whose name ends with Previews.lrdata. Do not delete anything else.

            Now launch Lightroom, and the previews will rebuild as you browse the Library.

            • 4. Re: Previews (pictures) not showing up in library module
              emick600 Level 1

              Thank you very much for the response. I had already done the first

              suggestion to no avail. The second suggestion I think sheds some light on

              what actually happened. When I look for that 'Previews.Irdata" file, it

              doesn't exist. Also in doing some further research within Lightroom I found

              when I try to open a single photo, it says "file cannot be found". Thinking

              back a little while, I was backing up and repositioning all my photos on

              the hard drive of the computer. In doing so, I think I kinda remember

              deleting some of those Lightroom folders from the hard drive, not really

              considering what hey actually were. (oops!)

               

              Not really sure where I should go from here. I assume the raw photos still

              exist in my other folders (haven't looked that deep yet), just all the post

              production work I did is gone. Not the end of the world. Should I

              re-install the Lightroom program, or will those important folders

              regenerate the next time I export/save/backup my work?

               

              On Thu, Oct 13, 2016 at 12:34 PM, Per Berntsen <forums_noreply@adobe.com>

              • 5. Re: Previews (pictures) not showing up in library module
                Per Berntsen Adobe Community Professional

                When you import photos, references to the location of files and folders are written to the catalog.

                If you move files or folders outside LR, it can no longer find them, and will display exclamation marks on the thumbnails and/or question marks on the folders. Are you seeing that?

                If so, follow the procedure here: Lightroom thinks my photos are missing—how do I fix it? - The Lightroom Queen

                 

                As for the missing previews folder, is it possible that you deleted it?

                And if you're on a Mac, I think the previews folder will show as a single file (package? I'm a Windows user).

                Once you have re-linked the missing photos/folders, the previews should rebuild, or maybe you'll need to tell LR to rebuild the previews. Not sure what happens when the previews folder is missing.

                Reinstalling is not going to fix anything, the catalog is not affected by a reinstall.

                • 6. Re: Previews (pictures) not showing up in library module
                  emick600 Level 1

                  Yes, the exclamation marks were there, and yes I believe I deleted the

                  previews folder. which actually probably is a blessing in disguise. I was

                  not happy at all with my organization techniques, so now I get to start

                  over and do it right. In doing my research I found a couple of videos on

                  importing and organization. I am going to look at those real close. Thank

                  you so much for all your help, you guys are the bomb!!!

                   

                  On Thu, Oct 13, 2016 at 3:28 PM, Per Berntsen <forums_noreply@adobe.com>

                  • 7. Re: Previews (pictures) not showing up in library module
                    Per Berntsen Adobe Community Professional

                    I was not happy at all with my organization techniques, so now I get to start over and do it right.

                    If you mean that you want to re-import everything, don't do it, you will lose all your edits, keywords, star ratings, etc.

                    It's much better to re-link all the missing photos, as described in the link I gave you.

                    Then, using a combination of LR and the OS, you can re-organize your library.

                    Do not use LR to move folders - there is a rare bug that sometimes will delete files when doing that - use the OS, and re-link the folder in LR afterwards.

                    You may find this article useful: Lightroom basics

                    • 8. Re: Previews (pictures) not showing up in library module
                      Just Shoot Me Adobe Community Professional

                      emick600 wrote:

                       

                      Yes, the exclamation marks were there, and yes I believe I deleted the

                      previews folder. which actually probably is a blessing in disguise. I was

                      not happy at all with my organization techniques, so now I get to start

                      over and do it right. In doing my research I found a couple of videos on

                      importing and organization. I am going to look at those real close. Thank

                      you so much for all your help, you guys are the bomb!!!

                       

                      On Thu, Oct 13, 2016 at 3:28 PM, Per Berntsen <forums_noreply@adobe.com>

                      The first set of sentences is troubling.

                      The Previews folder which is found in the same folder as the LR catalog is just that. IE a collection, a group of files, that LR generates to Show You Previews of your images in the Library module. It has nothing to do with any image file and folder organization. So if you actually delete your IMAGE FILES think those where the Preview those images are now gone (that is unless you have a backup of them).