2 Replies Latest reply on Oct 14, 2016 8:40 AM by birderpp

    I am using LR v5.6. Is this supported by Mac's OSX Sierra?

    birderpp Level 1

      I have a iMac running on OSX Lion. I wish to upgrade to OSX Sierra. Is LR5.6 supported by Sierra? If not, which is the next more recent version of LR that I need to upgrade to? I m not on the Adobe Cloud as this is a separately purchased edition of LR from years ago.