2 Replies Latest reply on Oct 14, 2016 3:29 PM by tebynum

    Problems getting a new custom puppet to move right

    tebynum

      Hello,

       

      Admittedly, I am very new to Character Animator.  I'm trying to create a custom puppet in Photoshop and bring it into Character Animator, but when I do the animation isn't right.  I've tried to mimic the settings of the Gavin puppet, but just not getting it to work right.  Below is a link to a YouTube video that shows an example.

       

      CH Help - YouTube

       

      Any feedback would be greatly appreciated.  Thanks!

        • 1. Re: Problems getting a new custom puppet to move right
          oksamurai Employee Moderator

          Hey Todd - Looking really good for a first custom puppet! What it looks like to me is that the mesh thinks it's a rectangle for some reason. This can be caused by several things like gaps or "islands" (stray unconnected parts) in the artwork.

           

          One thing you might want to try is, select your top-level puppet in the puppet panel, and on the right choose "contour" instead of "auto" for Layer Mesh. See if that helps.

           

          Check out 17 minutes into this tutorial video for a little more info about it:

           

           

          If it's still not working, please feel free to post the puppet here or DM it to me (via Google Drive, Dropbox, Creative Cloud, etc) and I can take a closer look.

          • 2. Re: Problems getting a new custom puppet to move right
            tebynum Level 1

            Fantastic!  I went into the artwork and there were a few stray pixels on the bodybg layer near the right hand.  I cleaned those up and retried the puppet.  The arms work much better now.

             

            Thanks so much for the quick response!