0 Replies Latest reply on Oct 20, 2016 8:59 AM by Vernma

    Phonegap JQ Mobile Datatables

    Vernma

      I don't know how to provide all the info you require. Developing app using Phonegap, JQ Mobile and DataTables. I use PhoneGap Desktop as server to test.

      It all works fine when connecting with Chrome. Here's a screenshot:

      Chrome.png

      When I connect with my phone, Android 5.0, Blu Studio Energy 2, the JQ Mobile behavior is lost. No styling, no page management. All the links seem to work. Here's a screen shot:

      Phone-2.png

      Here's my style and javascript includes (head section, behavior the same when I move scripts to body):

      <link rel="stylesheet" type="text/css" href="js/jqm/jquery.mobile-1.4.5.min.css" />
      <link rel="stylesheet" type="text/css" href="css/datatables.min.css" />

          <link rel="stylesheet" type="text/css" href="css/f2897.css" />

          <script src="js/jquery-1.11.3.min.js"></script>

          <script src="js/jqm/jquery.mobile-1.4.5.min.js"></script>

      <script src="js/datatables.min.js"></script>

          <script src="js/f2897.js"></script>

          <script src="cordova.js"></script>

                

      Using jquery 2.1.4 doesn't change anything.

      When I remove the DataTables script, the mobile behavior returns. But, of course, I would have to rewrite my tables.

      I see the same problem using PhoneGap CLI as server.

       

      Why would including the DataTables script cause this behavior only on my phone? Running latest PhoneGap Developer App on my phone to connect.

       

      BTW, all works fine using the Visual Studio Cordova as IDE as well. It uses ripple and chrome.

       

      I'm running under Windows 10.

       

      Things only fail with PhoneGap server connected to my phone.

       

      I'm a noob in the forum. TIA.