7 Replies Latest reply on Jul 25, 2017 4:33 PM by ger3rd@hotmail.com

    Lightroom "assertion failed"

    sandiv5623

      Lightroom 5.7 was working properly with a catalogue open, then I decided to create a new catalogue and it didn't work - 'assertion failed' is what came up when I tried to re-open lightroom. I am on a PC with windows 7 - no changes were made to OS. I have repaired, uninstalled and reinstalled to no avail. Any help would be greatly appreciated. thank you in advance ...

        • 1. Re: Lightroom "assertion failed"
          Sahil.Chawla Adobe Employee

          Hi Sandiv,

           

          Please refer to this article for the solution "Assertion failed" update error in Lightroom | Windows

           

          Let us know about the outcome.

           

          Regards,

           

          Sahil

          • 2. Re: Lightroom "assertion failed"
            WEDetails

            This same thing happened to me yesterday and I checked the pictures file in the registry and under user name and everything seems to be correct. I uninstalled and reinstalled lightroom and it still gives me the same message.

            Lightroom was working fine until I updated it. I am using Lightroom CC on a pc with windows 10.

            I am a photographer and need to edit photos! Help!!

            • 3. Re: Lightroom "assertion failed"
              Sahil.Chawla Adobe Employee

              Hi WEDetails,

               

              Could you please try the following steps:

               

              Ensure that the My Pictures virtual folder points to the Pictures folder under your user account folder by doing the following:

              1. Open Windows Explorer.
              2. Go to C:\Users\[your user name]\.
              3. Check for the folder named Pictures.
              4. If you don't see the folder, create a folder named Pictures under folder C:\Users\[your user name]\.
              5. Restart Lightroom. If the error recurs, restart your computer, then retry. If the error recurs, continue to the next step.
              6. Click the Windows Start button.
              7. Type "regedit" in the Search program and files field, and press the Enter key.
              8. Back up your registry by choosing File > Export. Give the backup copy of the registry a name and location you can remember.
              9. Navigate to the registry key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer \User Shell Folders]
              10. Look at the value for the My Pictures entry. The Windows default is: %USERPROFILE%\Pictures, which is the Pictures folder under C:\Users\[your user name]. If another folder is listed, check Windows Explorer for that folder. If it does not exist, you have two options. (1) Create the folder with that name in the location indicated in the registry entry. (2) If the Pictures folder exists under your user name folder, double-click the My Pictures entry, and reset the value to: %USERPROFILE%\Pictures
              11. Quit the registry editor.
              12. Log off from your account and back on, or restart your computer, then restart Lightroom

              Please let us know if it helps.

               

              Regards,

              Sahil

              • 4. Re: Lightroom "assertion failed"
                WEDetails Level 1

                Hi Sahil.Chawla,

                Thank you for sending an answer for my issue. I have looked at this solution but all my files and settings are set as they should be.

                I have also restarted my computer, uninstalled and reinstalled lightroom and restarted my computer after reinstalling it.

                It still does the exact same thing.

                I am desperate to get this issue solved as I am a photographer and have photos to edit.

                Any help would be appreciated!!

                 

                Thank you,

                Lavana

                • 5. Re: Lightroom "assertion failed"
                  alan carvalho fotografia

                  Estou passando pelo mesmo problema. todas as configurações estão ok.
                  ja desinstalei  e instalei tudo de novo e o problema continua

                  • 6. Re: Lightroom "assertion failed"
                    alan carvalho fotografia Level 1

                    também não resolveu aqui

                    • 7. Re: Lightroom "assertion failed"
                      ger3rd@hotmail.com

                      I am having the same problem - assertion failed. I did nothing to cause the problem. I sought help from Adobe. The first tech gave up and forwarded the problem to a higher level. The second tech created a new new administrative user and was able to access Lightroom. But he could not resolve the problem under my windows user account. He told me that I could use Lightroom under the new user account. I told him that was ridiculous because all of my other applications and files would not be accessible across my platform. He told me that I should contact Microsoft to have them assist me to move to a new user account. I think that is a ridiculous solution.

                       

                      I am at a loss as to what to do!