13 Replies Latest reply on Nov 5, 2016 7:05 PM by mopac

    Premiere Elements 13 Not Opening

    mopac

      Let me start off by saying that I have had Adobe Premiere Elements 13 installed on my computer and working fine for over a year. A few days ago I tried to open it and I got to the "welcome screen" but when I clicked on "video editor" and then "new project" it just sat there with the swirling purple loading bar and never actually opened. Also if I go directly into the application, skipping the "welcome screen", I just get an error saying that the program has stopped working before it ever loads. I have already tried a few things to fix this. First, I uninstalled PRE 13 and then reinstalled it, and it did the same thing. Then, I uninstalled both PRE and PSE 13 and deleted all the folders that had to do with the adobe products and then reinstalled them. Of course, that didn't work either. Then I took drastic measures and completely reset Windows and then installed PRE and it actually did open but only a few times then it went back to the same problem. Then I thought it could be because of a windows update. So I uninstalled all of those that I could and that didn't do anything either. A few other things to note: PRE 15 trial opens just fine on my computer, neither the licensed nor the trial versions of PRE 13 will open on my computer, PhotoShop Elements 13 opens on my computer, and PRE 13 opens on my laptop which is on the same version of Windows.

       

      System specs in case that's important

      Windows 10 (build 14393.351)

      Intel Core i7-4790K @4.4GHz

      32GB of 1600MHz DDR3 RAM

      Nvida GTX 970

      Gigabyte Z97 Motherboard

      250GB Samsung 850 evo for the boot drive (also where PRE is installed)

      Hitachi 3TB 7200RPM HDD for video and photo storage.

       

      It also might be worth noting that I build the system myself.