16 Replies Latest reply on Apr 6, 2017 12:50 PM by mstudniski

    selection issue bug on MacOS Sierra 10.12

    craigb33847621 Level 1

      I'm on a MacBook Pro (Retina, 15-inch, Mid 2015).

       

      When working with text, if I highlight text, whether it's a single letter, word, paragraph, etc. ... if I then go to the top panel and select any of the indent fields, space before/after, etc. the selection is highlighted gray, leaving the highlighted text in my copy highlighted blue ... therefore keeping the focus. So, when I type a measurement for an indent, space after, etc. instead it changes my copy. However, if I double click or select the top panel indent fields, space after, etc. it will highlight blue and allow me to enter my indent measurement.

       

      In my opinion this is a bug, it was not like this in prior versions of InDesign.

       

      It also does the exact same for the paragraph panel. However, the character panel and any other panel form what I can tell works as intended, where it highlights blue for you to change the value the first time.

       

      Has anyone else experienced this bug?

        • 1. Re: selection issue bug on MacOS Sierra 10.12
          Derek Cross Level 6

          Which version of InDesign?

          • 2. Re: selection issue bug on MacOS Sierra 10.12
            craigb33847621 Level 1

            Sorry about that. The latest InDesign CC 2017 release.

            • 3. Re: selection issue bug on MacOS Sierra 10.12
              Steve Werner Adobe Community Professional & MVP

              No problems for me in exactly the same configuration—Sierra + InDesign CC 2017.

               

              Try restoring your InDesign preferences:

               

              Trash, Replace, Reset, or Restore the application Preferences

              • 4. Re: selection issue bug on MacOS Sierra 10.12
                craigb33847621 Level 1

                I just restored my InDesign preferences and tried again. No luck.

                 

                See my quick video showcasing the issue below

                 

                • 5. Re: selection issue bug on MacOS Sierra 10.12
                  Dan Byer Level 1

                  My testing machine does the same thing with that same setup. How awful! Thankfully, I still use 10.11 and CC2015.3 on my main machine.

                   

                  With text selected…

                  I can't click and drag to select a value to be changed.

                  I can't click and cmd+a to select the whole value to be changed.

                  I can't click in the field and arrow up/down to make an increment change.

                  I can't click in the field and type to do math. (I will often type something like "+p6" at the end of the exisiting value to add 6 points to it. If I try that with this version, I end up with "0p06p+". It types the characters in backwards order? What? And when I hit return, the text that was selected is replaced with a return.)

                   

                  Note: you do not actually have to have text selected to use any of those paragraph settings as you're doing in your video. If your cursor is just sitting in the text, you can change any of those settings and they function exactly as expected. Similarly, if you're trying to make changes to the character settings, it seems to function exactly as expected. Trying doing any of that stuff in the character side of the Control Panel. Works fine, right? That said, you definitely shouldn't have to DEselect text to make changes to the paragraph values. And, on second thought, you MUST have text selected if you want to make changes to multiple paragraphs, so just placing your cursor in text to make paragraph changes is not an option.

                   

                  In messing with this, I noticed that this functions as expected if you first click in a value that you don't want to change before clicking on the value that you do want to change. For example: if you want to change the First Line Left Indent from 0p0 to 1p6, first click in ANY other box, and then click in the First Line Left Indent box, type "+1p6", hit return, and it will function exactly as expected.

                   

                  Also, if you just use the paragraph palette this works fine. The problem is only in the control bar.

                   

                  Aaaaand now none of my palettes will open. Great to see that bug still isn't fixed. :/

                  • 6. Re: selection issue bug on MacOS Sierra 10.12
                    craigb33847621 Level 1

                    I know I can click anywhere within text instead of highlighting it to select it. I was just highlighting it in the video to help show that I actually have selected something prior to trying to make adjustments. And in my case, the paragraph palette has the same issues. So, it's an issue (at least for me) with just the paragraph controls.

                     

                    Also, mine (as seen in the video), is doing the same. The first field I click in to make an adjustment won't work. However, once I click into another field I can make an adjustment. And as you said, I can't use the up or down arrows next to those fields either.

                    • 7. Re: selection issue bug on MacOS Sierra 10.12
                      Sarah Dukes Level 1

                      Actually, I have this problem in the panel, too.

                       

                      Overall in Sierra, my Intuos3 pen is buggy as heck, but nowhere is worse than in InDesign. Maybe that's because I use it the most all day. Are you both experiencing this problem with a mouse? If so, yeesh, there goes my backup plan.

                       

                      Could it be the Contextual OpenType alternates functionality (the little O that suggest ligatures when you have a character highlighted)? I've tried turning that off and it STILL won't disappear.

                       

                      Here are some other problems I'm having:

                      -Intuos3 pen has a hard time selecting items in Mac OS Finder windows.

                      -Sometimes when I try to move my pen off a selected item, the cursor will then act like I'm shift-clicking and then double-clicking, so it'll highlight 20 or so files and then OPEN all of them. This was disastrous when I was in my Applications folder... it basically opened all my applications at once.

                      -Latest Intuos3 driver from Wacom is installed and hasn't fixed this issue. Latest Sierra installed and issue still present.

                      -To get the Intuos pen to respond sometimes I have to mash the spacebar ...other times I used my MBP trackpad to get the input to register and then go back to my pen.

                       

                      Basically, it's taking 10 times as long to do ANYTHING. I used to prize my pen for making me so much faster, but now it's a hindrance.

                      • 8. Re: selection issue bug on MacOS Sierra 10.12
                        Lymper Level 1

                        Exactly the same with me. Using macOS Sierra 10.12.1 and InDesign CC 2017 (12.0.0.81 Build). I tend to use the window palets as I am using a 27" iMac and 27" display.

                        • 9. Re: selection issue bug on MacOS Sierra 10.12
                          shaung32953267

                          I have the same problem also, but I'm still running El Capitan.

                          I think it happened with the introduction of CC 2017

                          I found that using the preferences menu at the top rather than the palettes works OK.

                          • 10. Re: selection issue bug on MacOS Sierra 10.12
                            rat07

                            I have this problem too, but I haven't updated to Sierra etc. I can't use the top Paragraph palette without this issue. I get it highlighting beige or blue, which indicates I won't be able to type anything into a field (eg space after) without it replacing my text. Then sometimes I try and type something in (eg .5) and it puts in 05.mm (instead of 0.5mm) and my text disappears (as if bumped to a new text box on a different page).

                             

                            I've trashed preferences twice, I've uninstalled and reinstalled ID CC. This only started happening after the 2017 update. My video for reference (with extra notes):

                             

                            Adobe InDesign issue with the top paragraph palette - YouTube

                            • 11. Re: selection issue bug on MacOS Sierra 10.12
                              Frans van der Geest (ACP) Adobe Community Professional

                              Deselect Show OpenType ornament on Text frame and Selected text in the Extra Text Preferences. It is a known bug.

                              3 people found this helpful
                              • 12. Re: selection issue bug on MacOS Sierra 10.12
                                Momir Level 1

                                Thanks for the info and the workaround. Now that I deselected proper option it seems that all panels are working as expected.

                                 

                                I spent some time figuring out exact option that you have referred - so for clarity and understanding here is option in

                                Preferences > Advanced Type > Type Contextual Controls

                                named as

                                Show Adornment on Text Selection/Text Frame for more Type controls

                                which has to be deselected, in order to workaround this bug.

                                That is last one on this picture that I enclose - on picture it is selected, so deselect for workaround.

                                Screen Shot 2016-11-27 at 21.06.53.png

                                5 people found this helpful
                                • 13. Re: selection issue bug on MacOS Sierra 10.12
                                  rat07 Level 1

                                  Frans vdG - I think you've cracked it!! I've unchecked that button, and just based on two tests it seems to be fixed!! Hurrah!

                                   

                                  Thanks to Momir for clarifying with excellent instructions.

                                  • 14. Re: selection issue bug on MacOS Sierra 10.12
                                    Sarah Dukes Level 1

                                    THANK YOU!!! This fixed the panel problem.

                                     

                                    Now if Adobe and Apple would just get together and fix the terrible responsiveness of Intuos3 pens and Sierra... life might be normal again.

                                    • 15. Re: selection issue bug on MacOS Sierra 10.12
                                      craigb33847621 Level 1

                                      THANKS! That does indeed seem to have fixed the issue. I appreciate it.

                                      • 16. Re: selection issue bug on MacOS Sierra 10.12
                                        mstudniski Level 1

                                        This fixed it for me too! Thanks!