6 Replies Latest reply on Nov 12, 2017 10:10 AM by Jao vdL

    Lightroom extremely slow

    donsullivan

      I've read through all the posts here with the same complaint of performance problem and tried everything that's in them with absolutely no change. At this point LR is nearly unusably slow and seems to be getting worse over the last year instead of better. I'm getting ready to start looking at alternatives because there seems to be no relief in sight.

       

      I'm running on a late 2014 Retina 5K iMac

      Mac OS Sierra 10.12.1

      4GH Core i7 Processor

      32GB RAM

      Internal SSD for catalog and previews and external Thunderbolt drive for RAW master files

      AMD Radeon R9 M295X 4GB Graphics Card

      Lightroom CC CC 2015.7

      Primary images are uncompressed RAW from a Nikon D810 and some from a D500

       

      Examples of slow performance:

      - Select an individual image from the previews across the bottom. It takes 4-5 seconds (or more) for the image to load in full resolution on the screen

      - Tap Z to zoom for 1:1 takes 5 or more seconds depending on the image

       

      These are just a few examples of the slow performance but there are all kinds of stutters when shuttling through the thumbnails of photos in an individual folder or selecting tools or previews throughout. I've been using the same camera and computer for the last 2 years and when I got them both the performance of the solution was great. All of this performance problems have been introduced int he last 12 months and I have absolutely no performance problems with any other application that I use from any other provider; this is isolated to Lightroom. Over the last 12 months, using the exact same photos but successive updates to LR the performance just keeps declining more and more to the point where I'm just losing my patience to continue dealing with it. I can't have software that gets worse to use over time instead of better, especially at the price I'm paying for it. ! I'm ready to evaluate alternatives unless I see a real commitment to actually fix the seemingly almost universal complaint about LR.

        • 1. Re: Lightroom extremely slow
          dj_paige Level 9

          As an experiment, turn off the GPU acceleration in Lightroom and see if this improves. (Go to Preferences, click on the Performance tab, then uncheck the box).

           

          Also, please let us know if you are doing a lot of brusing and/or a lot of spot healing on your photos.

           

          Also, please state the EXACT make and model of your CPU.

          • 2. Re: Lightroom extremely slow
            donsullivan Level 1

            As noted above, I've already tried turning off GPU acceleration a number of times per other questions on this site and so far I've seen no measurable change in performance. I am occasionally doing some spot healing (10-15 per photo max for things like sensor dust in skies of random tree branches on the edge of a frame) and definitely doing some brushing. However, the performance problems for just general rending of an image is happening even on photos that have not been touched in any way in the Develop module.

             

            A little hard to find the 'exact' processor data since Apple doesn't expose the model number easily but from that I can find it's a Haswell, Quad Core 4.0GHz Core i7, Intel 4790K processor

            • 3. Re: Lightroom extremely slow
              dj_paige Level 9

              As an experiment, please create a new catalog, put a dozen or so photos in there (not important photos, though) and then edit the photos but DO NOT do any spot healing or brushing on the photos. Is the performance acceptable? Then continue to edit the photos with the usual amount of spot healing and brushing. Is the performance worse?

              • 4. Re: Lightroom extremely slow
                Anna Kucera

                Turning off turning off GPU  makes it slower for me

                 

                • 5. Re: Lightroom extremely slow
                  kaitairider Level 1

                  ADOBE LR CC/Classic.  DO NOT UPGRADE or PURCHASE.

                   

                  Hello, I  have seen major performance degradation since upgrading to Lightroom Classic 7.0.1 ala Mac Sierra 10.12.6.  Not even going to post me machine specs here, because I can confidently say they are adequate.

                   

                  I'm a real estate photographer, and I've been a pro user since Lightroom 3.  The most prominent increase in performance I noticed was the ability to create many HDR's at once.  Better memory allocation to that task I suppose.  However, overall the product has more degradations than improvements.  I've been working all weekend to kick out a simple shoot that generally takes six hours to produce. Most of the time wasted trying to get LR to work as it should.

                   

                  Here is a list of performance issues I've experienced.

                   

                  1. Import issues:  File corruption, and very degraded speed.

                   

                  2. Micro Lagtime between mouse movement and cursor on the screen, while in develop mode.

                   

                  3. Inconsistent behavior when creating panos and hdrs.  The new file created sometimes ends up at the end of the files sometimes placed with the originals.

                   

                  4. WB/Temperature seems off.

                   

                  5. Lens correction always needs more correcting.

                   

                  6. Is it me or has anyone else notice more noise issues than usual?

                   

                  7. Just switching images in the filmstrip (dev. Mode) is painfully slow.

                   

                  8. The forums are reporting the same info. But Adobe is taking little action to improve.

                   

                  NOW may be the time to forever ditch LR.  Adobe is now on my official "It Sucks" list.

                  • 6. Re: Lightroom extremely slow
                    Jao vdL Adobe Community Professional & MVP

                    donsullivan  wrote

                     

                    Examples of slow performance:

                    - Select an individual image from the previews across the bottom. It takes 4-5 seconds (or more) for the image to load in full resolution on the screen

                    - Tap Z to zoom for 1:1 takes 5 or more seconds depending on the image

                    This is pretty typical behavior for the preview cache not being up to snuff. Your 5k iMac has a 5120‑by‑2880 pixel screen. You likely have your standard preview size set way too low, forcing Lightroom to reload the images from raw every time. What is your standard preview setting in Lightroom's Catalog settings? Also, make sure that you actually have previews for your images. Select all in All photographs and have it generate standard previews (after you make sure the size is big enough to be displayed correctly on the extremely high resolution screen). This might take many hours but will improve this problem by quite a bit. Last make sure to empty the camera raw cache (preferences panel)

                     

                    Where are you trying to zoom 1:1? in Develop or grid view? In grid view it will generate a 1:1 preview of the entire image if you do that. If you don't have a 1:1 preview ready, it will take a few seconds as it has to serenader the entire image. In Develop, it just renders the area that you see, but with a 4120x2880 display that is almost the entire image and so will still take a few seconds. You'll see this behavior be much better if you turn off retina on Lightroom (get info in the finder), or make it's window only a quarter of the screen or so.