16 Replies Latest reply on May 26, 2017 6:29 PM by fitzfilmfx

    After Effects 2017 Playback is Extremely Slow

    JessicaLWhite Level 1

      I updated to After Effects 2017 upon its release and since then have had an incredibly slow experience. I migrated over all my settings and was achieving decent performance for the work I do (mostly text and simple image motion graphics; not very intensive stuff) with AE 2015.4 but since updating everything moves like molasses. Even on a fresh program with only a simple background and a text resizing keyframe, it takes 30 or 40 seconds for the preview to cache out and then playback never fully plays in real time. I don't know what settings to adjust to get the performance back to the smooth state it was in in AE 2015.4 but I'd rather not go back and re-install the older version. Has anyone else had this problem or been able to fix it? My system specs are below; again, it's not the most powerful machine on the block but it was able to handle at least relatively medium sized projects in After Effects before the update, so what gives?

       

      System:

       

      iMac (Retina 5K, 27-inch, Late 2014)

      Processor 3.5 GHz Intel Core i5

      Memory 32 GB 1600 MHz DDR3

      Graphics AMD Radeon R9 M290X 2048 MB

      OS MacOS Sierra 10.12.1

        • 1. Re: After Effects 2017 Playback is Extremely Slow
          andyc83834215 Level 1

          I am also experiencing poor RAM preview performance since updating to CC 2017.
          Basic 2D layer motion with no motion blur or semi-intensive effects on.

           

          The RAM preview loads but never lapses back to real-time after the initial render. Always red text, always well below real time.
          Seems to average around 15FPS.

           

          Seems to Pinwheel as well every single time, with different amounts of lag before regaining ability to interact with AE (usually 4 seconds or so.

           

          I have tried using Metal as renderer, OpenCL, software only. Same results.

          Cleaned caches, checked my RAM allocation settings, same results.

           

          iMac (Retina 5K, 27-inch, Late 2014)

          4 GHz Intel Core i7

          16 GB 1600 MHz DDR3

          AMD Radeon R9 M295X 4096 MB

          • 2. Re: After Effects 2017 Playback is Extremely Slow
            Szalam Adobe Community Professional & MVP

            This sounds like an extension/exacerbation of an issue that's been present on certain systems running recent MacOS's with AE versions 13.5 or greater. It has to do with changes in how AE's UI works coupled with changes Apple made in how the OS draws UI elements. It often happens with high res monitors, but not always.

             

            The AE team is aware of the issue and are working very hard on a fix. It's been an issue for a couple of years and they've done a few things that solved it for some folks, but not all. And, for some people, it's worse on the CC 2017 release.

             

            It doesn't take long to reinstall the old version (and you can keep the new version installed with no issues! ). So, if I were you, I would use the older version again until the next bug fix for AE comes out and see if it's better.

            • 3. Re: After Effects 2017 Playback is Extremely Slow
              kat40227628 Level 1

              i am having the same problem,

              I've come to the conclusion to not update after effects anymore because of all the bugs and everything.

              A fix?

              follow the instructions here Adobe CC 2015 Direct Download Links: Creative Cloud 2015 Release | ProDesignTools

              and just transfer all of your plugins back to the old version.

              And then remove that ****

              • 4. Re: After Effects 2017 Playback is Extremely Slow
                Szalam Adobe Community Professional & MVP

                Everybody who is having this issue, please install the latest update that came out last night: After Effects CC (November 2017) Bug-Fix Update Is Now Available

                 

                This update is 14.0.1 and might be a bug fix for this. It certainly fixes several other disturbing issues - especially for Mac users. It does not fix all the bugs that are new with the CC 2017 release (Known issues in After Effects CC 2017), but it does fix some issues that have been plaguing After Effects since the first parts of the new architecture showed up in the CC 2015 release.

                 

                If you can't see the update yet, you may need to wait a while until you see it as it can take up to 24 hours to populate an update across all the data centers. You may need to log out, relaunch the Creative Cloud app, and log in again.

                • 5. Re: After Effects 2017 Playback is Extremely Slow
                  nixart@gmail.com Level 1

                  Two things: 1. The new update is still crazy slow. And 2. I started a project in 2017 and I'd like to open that in 2015.3, but there's still no backwards compatibility. Not sure why that issue has been ignored for so long.

                  • 6. Re: After Effects 2017 Playback is Extremely Slow
                    Szalam Adobe Community Professional & MVP

                    nixart@gmail.com wrote:

                     

                    I started a project in 2017 and I'd like to open that in 2015.3, but there's still no backwards compatibility.

                    What? Yes there is! Just go to File>Save As version 13 (or however it words it - I'm not by my computer at the moment). The resulting file will be readable by CC 2014, CC 2015, and CC 2015 releases (which all used the same format).

                     

                    nixart@gmail.com wrote:

                     

                    The new update is still crazy slow.

                    Slower in what way? Doing what task?

                    • 7. Re: After Effects 2017 Playback is Extremely Slow
                      kapouevf Level 1

                      render time is crazy slow. Much slower than the last CC 2015 version.

                       

                      I render all my project with command line with the terminal (mac os) and the the CC2017 is much slower.

                      • 8. Re: After Effects 2017 Playback is Extremely Slow
                        nixart@gmail.com Level 1

                        On the backwards compatibility, hallelujah. I'm not by my comp now either, but can check on that later.

                         

                        On the slow issue, there's not much that isn't slower with this new release. I'll be candid here, but just know that the new AE has caused me a lot of stress over the past few days. I mainly see the slow-ness when I try and render out my timeline for playback. It's like it can't hold the whole timeline's worth of info, but 2015.3 could. I've got the GTX 1080 and 64GB of DDR4 RAM with an Intel 6800. Motion blur is rendered much slower. Rendering is fine when using AME. I don't use AE's internal renderer anymore unfortunately because of the lack of QT support for Windows through just that program. Premiere's QT works fine. But that's another issue.

                         

                        Sometimes when I turn on AE, it says that hardware acceleration has been turned off. Not sure why since the hardware stays the same. And I can't seem to recreate the error on purpose. It'll just happen and I have to restart the app.

                         

                        Expressions slow down project files more than usual as well.

                         

                        Also as another issue, the tabs are harder to use and see now. I use a lot of custom and purchased scripts in my workflow, so the tabs tend to stack up. Now, the tab scroll bar is gone, and it's hard to tell where the tab begins and ends, so navigating through those is substantially worse to me than the previous release. The timeline also looks more cluttered with the new UI change and the round buttons take up more screen space and (my opinion) look childish. Is beta-testing with actual customers part of your workflow?

                         

                        It'd be amazing if these among many issues could be resolved before you guys worry about more features. Colleagues and I don't really care about more features. We just want a reliable product. If I could actually trust that new features would be usable when they're released onto an already-reliable platform, then I'd be game for more features, but at the moment, if you can't even get the rendering engine to work right, that's a huge problem.

                         

                        And by the way, thank you for replying. I haven't had any luck in that department when contacting Adobe.

                        • 9. Re: After Effects 2017 Playback is Extremely Slow
                          Szalam Adobe Community Professional & MVP

                          nixart@gmail.com wrote:

                           

                          I don't use AE's internal renderer anymore unfortunately because of the lack of QT support for Windows through just that program. Premiere's QT works fine. But that's another issue.

                          What QuickTime support issues are you talking about? You can have QuickTime installed on Windows safely if you only install the QuickTime essential components and don't install the extra stuff like the web player that Apple is leaving unsecured. But, even if you don't install QuickTime, After Effects has QuickTime stuff in it natively now. I know that some stuff isn't exactly the same, but it's been useable for me so far.

                           

                          nixart@gmail.com wrote:

                           

                          Sometimes when I turn on AE, it says that hardware acceleration has been turned off. Not sure why since the hardware stays the same. And I can't seem to recreate the error on purpose. It'll just happen and I have to restart the app.

                          You're not the first person to report issues like this. In other forum posts I've seen, this was usually caused by some seemingly unrelated other software on the system (like TeamViewer, I think). Basically, remote desktop causes AE to not be able to use hardware acceleration on the panels, etc.

                           

                          nixart@gmail.com wrote:

                           

                          The timeline also looks more cluttered with the new UI change and the round buttons take up more screen space and (my opinion) look childish. Is beta-testing with actual customers part of your workflow?

                          I'm not an Adobe employee, so I don't have any customers other than my freelance clients. I am just an "actual customer" of Adobe like you. I really like some parts of the new UI, but there are some parts that really could use a cleanup. I'd recommend filing a bug report on any UI elements that are interfering with your work as you describe. And please be specific about the issue. Just saying you don't like it and you want it to go back to the way it was isn't as helpful as saying what, specifically is making it difficult to work with. They are very unlikely to go back, but they can certainly move forward in better ways.

                           

                          nixart@gmail.com wrote:

                           

                          It'd be amazing if these among many issues could be resolved before you guys worry about more features. Colleagues and I don't really care about more features. We just want a reliable product. If I could actually trust that new features would be usable when they're released onto an already-reliable platform, then I'd be game for more features, but at the moment, if you can't even get the rendering engine to work right, that's a huge problem.

                           

                          Again, I'm not one of the "you guys" I think you're referring to. I am not an employee of Adobe. I'm a user too. I just help out a lot around the forums so I got a fancy badge.

                           

                           

                          nixart@gmail.com wrote:

                          And by the way, thank you for replying. I haven't had any luck in that department when contacting Adobe.

                          You're welcome! And I'm sorry it took so long for me to reply to you this time. I had a bunch of work at my full-time job (mostly 3d animation and After Effects work, but also some running around outside with cameras) and I haven't had time to get on these forums very much recently.

                          • 10. Re: After Effects 2017 Playback is Extremely Slow
                            omar idi Level 1

                            I had exactly the same problem as JessicaLWhite, and after updating is working fine again. This reminds me to never update straight away to the new versions, I had almost the same issues updating to Adobe CC 2015...

                             

                            Thanks!

                            • 11. Re: After Effects 2017 Playback is Extremely Slow
                              claudiakunin Level 1

                              having the same issue....I called adobe, and someone tweaked the preferences in the library? on a shared screen.....

                              everything worked much better after that....

                               

                              thank you India!

                              • 12. Re: After Effects 2017 Playback is Extremely Slow
                                Roei Tzoref Adobe Community Professional
                                and someone tweaked the preferences in the library? on a shared screen.....

                                next time take notes and share with the rest of us

                                • 13. Re: After Effects 2017 Playback is Extremely Slow
                                  misterhengel Level 1

                                  Yeah- I am not able to open my project file in 2015.4 after working on this huge client project in 2017 version. Now i"m really worried... It was running fine then all the sudden in the middle of the day RAM preview started dropping frames consistently. How do you save files for backwards compatibility?

                                   

                                  EDIT: ok so I figure it out. I called support and they said the reason the frames are dropping when RAM preview attempts to cache is because the folder was altered in some way (could be any number of reasons why). Anyhow - they said if you go to adobe through appdata and look for the folder called 'roaming'>then open "commmon"  then find all your aftereffects folders and rename them to Aftereffects_old , open the program and it should work. at least it does for me.

                                   

                                  Huge life saver. I'm always surprised how much their customer care team can help.

                                  1 person found this helpful
                                  • 14. Re: After Effects 2017 Playback is Extremely Slow
                                    u_felski Level 1

                                    Hi all,

                                    check out this thread,

                                    GPU Issue after Upgrade to Premiere Pro CC 2017   (post by pablocricket2) I just managed to speed up realtime performance by at least 4 times ON GPU ACCELERATED FX (like glow) on AE cc 2017 on my Mac, will try Win too. There is an app, gpu-z( win) or cuda-z (mac). I just started the app, launched AE and WHACK!! it ran. No Terminal Cuda Card text entries and all that (been through that too since cs6).

                                     

                                    CUDA-Z

                                    GPU-Z - Info-Tool für Grafikkarten und GPUs

                                    • 15. Re: After Effects 2017 Playback is Extremely Slow
                                      Szalam Adobe Community Professional & MVP

                                      misterhengel  wrote

                                       

                                      Yeah- I am not able to open my project file in 2015.4 after working on this huge client project in 2017 version. Now i"m really worried... It was running fine then all the sudden in the middle of the day RAM preview started dropping frames consistently. How do you save files for backwards compatibility?

                                      In After Effects, go to File>Save As and there's an option to save it for the AE CC version 13s (That is, it can be opened in CC 2014, CC 2015, and CC 2015.3).

                                      • 16. Re: After Effects 2017 Playback is Extremely Slow
                                        fitzfilmfx Level 1

                                        I still get playback issues on windows. After cache is finished, I get a choppy 15fps playback. One thing I noticed, is that it only seems to do this once the composition resolution size reaches 4k.