2 Replies Latest reply on Nov 13, 2016 3:21 AM by Bruyn

    Can't update to Lightroom 6.4 from 6.0

    Bruyn

      I just upgraded to Lightroom 6 from 5.7.
      I have to upgrade to 6.4 for support for my new Fujifilm X70 camera. The update failed and now Adobe Application Manager no longer works.
      I downloaded Adobe Application Manager but it won't install.
      I get the message: Installer failed to initialize. Please download SupportAdvisor. When I click on the link it states that SupportAdbvisor had been discontinued!!4bi

       

      I'm running WIndows 7 64bit.