2 Replies Latest reply on Dec 22, 2008 6:16 AM by Newsgroup_User

    Zoom Question

    Level 7
      Dear All,

      I have created a flash swf file which when viewed seems to large on the
      screen for my needs but when I select 100% in the flash player, it seems
      perfect. I am unsure what % the player is viewing at if the 100% choice on
      the player is perfect for my needs.

      I plan to take this swf and load it into another application but I am unsure
      how to scale it down to the 100% player option. Is there a scaling option
      over and above the Scale property of the swf. When I check the swf loaded
      into my application and set the zoom to 100% it is not the same as the
      player 100%, so I am confused. Can anyone offer me some advice?

      Thanks again,

      Alastair

        • 1. Re: Zoom Question
          robdillon Most Valuable Participant
          If you don't want to scale your movie, then use the Match Movie selection for the Dimensions option in the HTML tab of the Publish Settings window. Set the Scale option to Default.
          • 2. Re: Zoom Question
            Level 7
            Rob,

            Thanks very much for the speedy reply. I must admit that I was not aware of
            this setting. When I checked I have the Scale as Default (show all). If I
            double click the swf on my pc the flash player comes up with the swf at
            about 3/4 of the screen, but when I display it full screen, the contents are
            blown up and it looks pixilated. If I change it to 100% it looks fine. What
            you suggest makes sense but it does not apparently work in this swf file. I
            am using CS3, Version FP 8, with Actionpscript2. Nowhere in my fla do I
            mention any scaling such as NoScale. I'll try that instead.

            I have changed the actionscript to Stage.scaleMode = "noScale" and this does
            work.

            I appreciate your reply and thanks for your time and the pointer to the
            answer.

            Alsatair


            "Rob Dillon" <rob@ddg-designs.com> wrote in message
            news:gio3o1$hg4$1@forums.macromedia.com...
            > If you don't want to scale your movie, then use the Match Movie selection
            > for the Dimensions option in the HTML tab of the Publish Settings window.
            > Set the Scale option to Default.