10 Replies Latest reply on Nov 15, 2016 1:14 PM by tmdavisart

    CS6 AE Keylight 1.2 Issues

    tmdavisart

      I'm having an issue green screening where I get a glitch in the final product. I've attached the screenshot to this post. I thought if I changed the method from 'Soft Color' to 'Source' then it would be fine, but I am having the same problem.

       

      Are there any settings I can change to eliminate this What am I doing wrong that is making the green screen bleed through the final result?

       

      Screen Shot 2016-11-15 at 12.52.51 PM.png

        • 1. Re: CS6 AE Keylight 1.2 Issues
          Mylenium Most Valuable Participant

          We can't know. You are talking about settings, but you are not showing them to us nor are you offering any additional info like screenshots of the unkeyed source footage and its properties, system info and so on. For all we know, this could be a glitch in the source footage that throws the plug-in off just as it could be e.g. a problem with Fast Draft display and your comp resolution not being at Full/ 100% zoom plus a gigazillion other things. you have to be much more specific and provide the relevant information.

           

          Mylenium

          • 2. Re: CS6 AE Keylight 1.2 Issues
            tmdavisart Level 1

            Screen Shot 2016-11-15 at 1.09.36 PM.png

             

            I used the Keylight 1.2 effect in After Effects CS6. Traced the shape around him and eye-dropped the green like I usually do. Changing the Replace Method to another setting usually fixed the issues I've had with green screen footage. Here are the settings I've put in to get the key in the final product.

             

            I'm not super familiar with how it works, I've been learning as I go along. Are there any different values I should use for the key to be better?

            • 3. Re: CS6 AE Keylight 1.2 Issues
              Szalam Adobe Community Professional & MVP

              What, exact, version of AE CS6 do you have? If it's not 11.0.4, you should consider updating.

              What is the codec that MOV file is encoded with?

              • 4. Re: CS6 AE Keylight 1.2 Issues
                Mylenium Most Valuable Participant

                Do not use masks unless you actually assign them as garbage mattes in the plug-in interface! That's where your issues come from. If at all, apply it after the keying or as a minor, pre-compose the masked content. Keyoing plug-ins simply don't like messing with transparency outside their own little world.

                 

                Mylenium

                • 5. Re: CS6 AE Keylight 1.2 Issues
                  tmdavisart Level 1

                  How would I key without removing the green first with the mask? Is there a more effective key?

                  • 6. Re: CS6 AE Keylight 1.2 Issues
                    Dave LaRonde Level 6

                    I see this is a Quicktime Movie.  What's the codec?  H.264?  If so, I'd try transcoding it to something like a QT in Photo JPEG, PNG, JPEG 2000 or Animation codecs.

                     

                    I'm highly skeptical of the way AE treats highly-compressed footage like H.264.

                    1 person found this helpful
                    • 7. Re: CS6 AE Keylight 1.2 Issues
                      tmdavisart Level 1

                      Yes, I rendered it as H.264 1080P 29.97

                      I will try those instead

                      • 8. Re: CS6 AE Keylight 1.2 Issues
                        Szalam Adobe Community Professional & MVP

                        tmdavisart wrote:

                         

                        How would I key without removing the green first with the mask? Is there a more effective key?

                        I think Mylenium was suggesting that you use the Inside Mask and Outside Mask features inside Keylight or precompose the footage (moving all attributes into the precomp) with the masks in there and then, back in your main comp, apply Keylight to your precomp.

                        • 9. Re: CS6 AE Keylight 1.2 Issues
                          Dave LaRonde Level 6

                          tmdavisart wrote:

                           

                          Yes, I rendered it as H.264 1080P 29.97

                           

                          Actually, I was talking about the source footage.  If it's also H.264, I would transcode it.  You can tell by highlighting the clip in the Project pane and looking at the info at the top.

                           

                          If H.264 is your DELIVERY codec, that should be okay.

                          • 10. Re: CS6 AE Keylight 1.2 Issues
                            tmdavisart Level 1

                            Oh, ok. The source footage is a QT. Maybe I can try transcoding it to some of those other codecs you mentioned.

                            I appreciate the help so far, I'm trying to eliminate this issue for work.