0 Replies Latest reply on Nov 20, 2016 11:15 AM by benjamino96587917

    Is "CFBundleShortVersionString" still required in config.xml for ios?

    benjamino96587917 Level 1

      Hi All,

       

      I was using weinre to debug my app, and I got an error from the code-push plugin I have included.

       

      [CodePush] 400: An update check must include a binary version that conforms to the semver standard (e.g. '1.0.0'). The binary version is normally inferred from the App Store/Play Store version configured with your app.

       

      This prompted me to ask if the below config-file element is still required in the config.xml file for PGB?

       

      <config-file platform="ios" parent="CFBundleShortVersionString">

      <string>210</string>

      </config-file>

       

      Or does the version defined in widget suffice now?

      <widget version = "2.1.0">

       

      If it is, what format should the string be in?

      <string>210</string>

      OR

      <string>2.1.0</string>

       

      I have also asked the same question in the code-push forum to find out if the plugin isn't reading the app correctly.

       

      Thanks in advance for your replies