4 Replies Latest reply on Nov 24, 2016 8:13 AM by dldpower2plan

    Invalid binary in Application Loader. Possible certificate issue after expiration

    dldpower2plan

      Hi,

       

      I've built my PhoneGap application without any problems until our Apple Development subscription expired (I guess, all the certificates expired as well). While renewing our Apple dev program at our company, my boss made me a new account and added me as admin to the company. I tried remaking the certificates, and while all my builds worked over at PhoneGap Build (means, that the certificates are valid), while trying to submit our app via the Application Loader, I get a binary error, and can't go any further.

       

      Upon browsing the forums I've found out that this could be an issue with the certificates, so I came here to ask, what could be wrong with my setup.

       

      I have to specify, that before this expiration happened, all our builds were submitted by using a Macbook, that is no longer available, so I can't access the old keychain information.

       

      Also, another important information: while struggling with this issue, I remade all the certificates and profiles. (the App ID remains the same, since i don't need to change anything there)

       

      Another note: our application supports push notifications, so I added that to the App ID, and created 2 certificates: Apple Development iOS Push Services and Apple Push Services. (I don't know if I need both, but I followed a tutorial, and it worked perfectly until the recent happenings)

       

      We couldn't release our app for weeks now, which is a huge problem right now, so any help would be appreciated.