1 Reply Latest reply on Nov 24, 2016 2:26 PM by ryanskihead

    Please upgrade the version of any plugins that may include the following file: GCMIntentService.java

    johnm10449311

      Hi,

       

      I'm getting a build error on PGB for Android. I'm targetting cli-5.4.1 but have also tried 5.2.0. My plugin is declared as instructed by the plugin developers in the config.xml as:

       

      <preference name="android-build-tool" value="gradle" />

      <plugin name="phonegap-plugin-push" version="1.8.4" source="npm">

          <variable name="SENDER_ID" value="999982169362" />

        </plugin>

       

      I cannot use the latest version of the plugin (1.9.0) because PGB doesn't support cli-6.4.0 yet.

       

      The build errors from the log are:

       

      :generateReleaseSources

      :compileReleaseJava/project/src/com/adobe/phonegap/push/GCMIntentService.java:451: error: cannot find symbol

        Log.d(LOG_TAG, "Version: " + android.os.Build.VERSION.SDK_INT + " = " + android.os.Build.VERSION_CODES.M);

        ^

        symbol: variable M

        location: class VERSION_CODES

      /project/src/com/adobe/phonegap/push/GCMIntentService.java:452: error: cannot find symbol

        if (android.os.Build.VERSION.SDK_INT <= android.os.Build.VERSION_CODES.M) {

        ^

        symbol: variable M

        location: class VERSION_CODES

      /project/src/com/adobe/phonegap/push/GCMIntentService.java:462: error: cannot find symbol

        if (android.os.Build.VERSION.SDK_INT <= android.os.Build.VERSION_CODES.M) {

       

      Does anyone know why this is failing and what I can do to fix it?

       

      Thanks,

      John