19 Replies Latest reply on Nov 29, 2016 4:54 PM by Jeff Almasol

    Character Animator not responding after loading

    rchilders8

      I am an Adobe Creative Cloud user. I upgraded my computer with a new motherboard and 16 GB of Ram and a 1TB solid state drive. All off the rest of my applications run fine but when Character Animator loads it greys out and gives a not responding message. I have uninstalled and then reinstalled the software but the problem is still occurring. Any ideas what my problem is?

        • 1. Re: Character Animator not responding after loading
          CoSA_DaveS Adobe Employee

          What operating system version and camera are you using? Can you post a screen shot of the hung app?

          • 2. Re: Character Animator not responding after loading
            rchilders8 Level 1

            I am running Windows 8.1 and using a Logitech web cam. Here is the screen shot and system information.

            • 3. Re: Character Animator not responding after loading
              oksamurai Employee Moderator

              The fact that all other CC apps are running but this one isn't makes me wonder if it has something to do with the camera, as that's the one thing that seems unique to CH.

               

              Does it help if the webcam is unplugged? (Not useful I know, just curious if it runs at all without it).

               

              Sometimes a conflicting program can cause issues - is anything else running in the background that could possibly conflict with camera and/or microphone resources?

              • 4. Re: Character Animator not responding after loading
                Jeff Almasol Adobe Employee

                What sort of GPU do you have in your machine, and do you have the latest qualified/supported driver installed for it?

                 

                In System Information, twirl open the Components section and select Display, then post a screenshot of that info?

                 

                After you quit/close Character Animator, can you open Task Manager to see if there are any extra Character Animator.exe processes still running? If so, end those processes, then try launching again?

                • 5. Re: Character Animator not responding after loading
                  rchilders8 Level 1

                  no character animator processes running after closing.

                   

                  • 6. Re: Character Animator not responding after loading
                    rchilders8 Level 1

                    no difference if the webcam is present or not. Character Animator was running fine before I upgraded my computer so it must have something to do with the upgrade. All of the hardware info is posted above. I have been animating for over 35 years so I am not exactly a casual user. I am using the software with a group of students to create a pilot for a television comedy about the developmentally disabled.

                    • 7. Re: Character Animator not responding after loading
                      rchilders8 Level 1

                      It seems odd that the software loads and then hangs up. It seems to run into some conflict when it is about to look for a file.

                      • 8. Re: Character Animator not responding after loading
                        rchilders8 Level 1

                        It seems odd that the software loads and then hangs up. It seems to run into some conflict when it is about to look for a file.

                        • 9. Re: Character Animator not responding after loading
                          Jeff Almasol Adobe Employee

                          OK, can you try a few other things...

                           

                          1. Open a File Explorer window, then navigate to your user Documents folder (e.g., C:\Users\yourusername\Documents), then navigate into the Adobe\Character Animator\Beta subfolder. First, does that Beta folder exist? If so, do you just see one subfolder in it called "Character Animator Project"? If so, try renaming or deleting that folder.

                           

                          2. Navigate to the C:\Users\yourusername\AppData\Roaming\Adobe\Character Animator\ folder, then rename the Beta subfolder to something else.

                           

                          3. Try relaunching Character Animator.

                           

                           

                          If that still doesn't work, try launching Character Animator from the command line, as follows:

                           

                          1. Open a Command Prompt window.

                          2. Change to the Character Animator app folder by typing:  cd "C:\Program Files\Adobe\Adobe Character Animator CC (Beta)\Support Files"  then pressing Enter.

                          3. Type    Ch    then press Tab, which should auto-complete it to "Character Animator.exe". Then, press Enter to start the app.

                           

                          If it still fails to launch, does the command prompt window show any error messages?

                           

                           

                          Other questions:

                          -- I'm assuming audio recording and playback are working properly in other applications on your machine?

                          -- Do you have any other video capture devices/programs running at the time you launch Character Animator? If so, does temporarily disabling them help?

                          • 10. Re: Character Animator not responding after loading
                            DanTull Adobe Employee

                            One experiment to try while the hang is still repeatable would be to gather a process dump file. If you can send that to me, I can try to figure out what Character Animator is doing when it gets stuck.

                             

                            The easiest way to create one goes something like this (possibly slightly off because I don't have 8.1 handy and apologies in advance that the directions are a bit involved):

                            1. Right click in the Windows task bar and choose "Task manager" from the menu.

                            2. You may need to click an arrow to show "More Details"

                            3. Right click Character Animator in the processes list.

                            4. There should be a menu item that says "Create dump file."

                            5. After it finishes, it should show a dialog that has the path to the dump file.

                            6. Without closing the dialog, open a File Explorer window.

                            7. Navigate to the folder where the DMP file indicated in the dialog is located.

                            8. Right click the DMP file and choose "Compressed (zipped) folder" from the send to menu.

                             

                            Unfortunately DMP files can be a bit big and they often don't compress very well, but if you can use a file transfer service or Google Drive/Dropbox/etc to send the zipped DMP file to me, I'd be happy to try to see where Character Animator is getting hung up.

                             

                            Hopefully that'll at least give us some ideas of what to try to get it unstuck and what we should change to fix this issue.

                             

                            Thanks -- Dan Tull

                            • 11. Re: Character Animator not responding after loading
                              rchilders8 Level 1

                              First, I really want to thank you guys for working so hard on this with me. When I try to go to C:\Users\yourusername\AppData\Roaming\Adobe\Character Animator\ I do not find an AppData folder at all. I tried the command line approach but I got path does not exist message

                              • 12. Re: Character Animator not responding after loading
                                rchilders8 Level 1

                                I created the dump file which it say is located at c:\users\richard\AppData\Local\|CharacterAnimator.dmp. When I open the file explorer window, there is no appData folder visible at all. How do I get to it?

                                • 13. Re: Character Animator not responding after loading
                                  rchilders8 Level 1

                                  Any chance we can do a remote log in?

                                  • 14. Re: Character Animator not responding after loading
                                    Jeff Almasol Adobe Employee

                                    Sure. Just let us know the best time today (including your time zone) that works for you. I'm travelling this morning/afternoon (Pacific time), but one of my colleagues might be able to assist if I can't.

                                     

                                    Some other things to check...

                                     

                                    -- In File Explorer, can you try showing hidden files (How to see hidden files in Windows 8 ) and does that help access the AppData folder?

                                     

                                    -- In File Explorer's address bar, if you type:   %appdata%    does that navigate to the AppData folder?

                                     

                                    If either work, hopefully you can find the CharacterAnimator.dmp file that you can send us.

                                     

                                    Thanks.

                                    • 15. Re: Character Animator not responding after loading
                                      rchilders8 Level 1

                                      I am in Marin so Pacific time. 3:30 would work great for me.

                                      • 16. Re: Character Animator not responding after loading
                                        rchilders8 Level 1

                                        Ok, got to the app data folder. Did another dump file and it said it was stored at C:\Users\richard\AppData\Local\Temp\Character Animator (2).DMP. When I drill down, there is no character animator file in the temp folder. Curiouser and curiouser.

                                        • 17. Re: Character Animator not responding after loading
                                          DanTull Adobe Employee

                                          Weird. I've never had the DMP file not get created as indicated. I will note the Temp folder can get pretty cluttered, so I usually switch it to detail mode (right click and pick detail in the view menu) and then click the date modified column to force the most recently modified files to the top of the list.

                                           

                                          Hopefully that helps.

                                           

                                          DT

                                          • 18. Re: Character Animator not responding after loading
                                            Jeff Almasol Adobe Employee

                                            Does the .DMP file exist while the crash error message is still visible in Character Animator?

                                             

                                            If 3:30pm is a good time, I'll send you a direct message with details and to get a phone number to call. Thanks.

                                            • 19. Re: Character Animator not responding after loading
                                              Jeff Almasol Adobe Employee

                                              Talked over the phone, and there seemed to be a conflict with the Nahimic audio driver or process that was running. (Nahimic software was included as part of his new MSI motherboard.) Killing the three Nahimic processes allowed Character Animator to launch, then relaunching Nahimic still allowed Character Animator to launch. I have the crash dump and will investigate what might be happening, but the Nahimic software might've changed some default audio driver or setting that was somehow incompatible with Character Animator initializing its audio subsystem.

                                               

                                              Character Animator is now working.