9 Replies Latest reply on May 5, 2017 12:42 PM by dannyscot

    Edit Capture Time not working for multiple photos

    stnz Level 1

      Hello,

       

      I seem to have a strange problem with the Edit Capture Time function. According to earlier forum posts and other sources it SHOULD work for changing time of multiple photos, but I cannot get that to work. The timezone shift only changes the capture time of the first picture selected (and shown), not other selected pictures. Lightroom is the newest version, and actually I have had the same behaviour for a year or so, all the time with current newest version of Lightroom CC. I think it used to work just fine earlier, but that was at least a year ago.

       

      Would be nice to get that to work, clicking every photo separately isn't really handy. Stupid mobile phones save their photos with local time as capture time and not UTC.. So to use the photos in the same galleries with photos taken with other cameras while traveling through multiple timezones requires changing capture time manually.

       

      Any ideas? Should it work? Does anyone have it working at the moment with the newest version? Not sure if it works when setting static new capture time, but at least the timezone shift does not.

        • 1. Re: Edit Capture Time not working for multiple photos
          johnrellis Most Valuable Participant

          I just retested Edit Capture Time with Shift By Set Number Of Hours after selecting multiple photos, and it successfully changed the photos capture time by the given number of hours. 

           

          Please report the exact version of LR and Windows / Mac by doing Help > System Info.  (LR often fools people into mistakenly thinking they're on the "latest" version.)

           

          LR CC 2015.7 introduce a bug where photos don't automatically re-sort properly after doing Edit Capture Time. You need to click the Sort Direction button twice:

          If that doesn't help, then the most efficient way to troubleshoot is to see exactly what's on your screen: Post a series of full-resolution screen shots of the entire LR window for each step, showing grid view before Edit Capture Time, the Edit Capture Time window, and grid view after Edit Capture Time.  Make sure the capture times are showing under the thumbnails (do View > View Options).

          1 person found this helpful
          • 2. Re: Edit Capture Time not working for multiple photos
            stnz Level 1

            Version details:

            Lightroom version: CC 2015.7 [ 1090788 ]

            License: Creative Cloud

            Operating system: Mac OS 10

            Version: 10.12 [0]

            Application architecture: x64

             

            And hmhm.. Now I actually cannot reproduce it myself, after having the problem in real use for long time.

             

            I will update the screenshots when I can actually reproduce the problem.

            • 3. Re: Edit Capture Time not working for multiple photos
              stnz Level 1

              Ok, found my mistake. It only works when you are in grid view. If you are in loupe view, it doesn't work even if you select multiple photos from the film strip, which is what I was trying to do.

              • 4. Re: Edit Capture Time not working for multiple photos
                johnrellis Most Valuable Participant

                Very good, glad you got it solved. 

                 

                That's one reason we ask for screenshots -- it clarifies exactly when a problem is happening and provides lots of details that are missing from the written descriptions.

                 

                The way that LR handles multiple selections in filmstrip has long caused confusion.  Adobe has good justifications for why it behaves the way it does, but nevertheless people have continued to report confusion over the years, indicating that Adobe's solution could be improved.

                 

                In your case, you quite reasonably didn't notice the small difference in Edit Capture Time between grid view and loupe view when multiple photos are selected:

                I've long been quite aware of that difference but often forget about it when people ask questions.

                1 person found this helpful
                • 5. Re: Edit Capture Time not working for multiple photos
                  Just Shoot Me Adobe Community Professional

                  stnz wrote:

                   

                  Ok, found my mistake. It only works when you are in grid view. If you are in loupe view, it doesn't work even if you select multiple photos from the film strip, which is what I was trying to do.

                  The film strip never works for selecting multiple images. It is basically just a VIEW portal to show you what is in the folder you have selected in the Folders section on the left hand side or what you have selected in the Catalog section also on the left hand side.

                   

                  This is a common mistake that even I have made over the years. Been using LR since version 1.

                  • 6. Re: Edit Capture Time not working for multiple photos
                    stnz Level 1

                    Well, it works for export for example. Kinda confusing user interface design.

                    • 7. Re: Edit Capture Time not working for multiple photos
                      Guy in Seattle Level 1

                      +1 on very confusing interface

                      • 8. Re: Edit Capture Time not working for multiple photos
                        dannyscot Level 1

                        Ty stnz!  This was driving me nuts (none of the examples I found mention you have to be in the Grid view).