12 Replies Latest reply on Dec 1, 2016 11:23 AM by Roei Tzoref

    AE 2017 Bug - Time Remapping

    angelodc

      Hi there. I only just updated to AE 2017, but when I reopened a certain project---which relied heavily on time remapping---the animation was completely out of sync with the voice over. Has anyone else run in to this? (Just in case you're wondering what exactly I was time remapping, a client had asked me to make animation based on their Power Point slides. So, I made screen recordings of the slides and retimed them in After Effects according to the voice over.) The project was fine before I updated to 2017.

        • 1. Re: AE 2017 Bug - Time Remapping
          Roei Tzoref Adobe Community Professional

          did you open the same project in another version and it behaved as expected? you can run alongside 2015 and 2017 (and all other version from CS6 and above)

           

          are you using mp3 for audio? show us some screenshots or video capture if possible.

          • 2. Re: AE 2017 Bug - Time Remapping
            angelodc Level 1

            Thanks for the reply.

             

            Yes, I made the original project in 2015 and it was working fine. (But, again, when I updated to 2017, it doesn't work.)

            How do I access 2015? Is it still on my computer? (I'm on a Mac, and I don't see it in my Applications folder anymore. Does Adobe automatically remove it upon updating?)

             

            Audio was .wav and is working fine.

             

            I'm not sure if my employer would be okay with me posting screen shots.

            • 3. Re: AE 2017 Bug - Time Remapping
              Roei Tzoref Adobe Community Professional
              How do I access 2015? Is it still on my computer?

              by default upon updating, the CC APP removes previous versions. so if you don't see it on applications, it's probably uninstalled. you can always re-install it through the CC App. you can see it under previous versions section. this could help solve this problem if you could determine that in CC2015 it works fine.

               

              there is not TR bug in recent version that AFIK. could it be just a preview issue? are you previewing cached frames? (the green bar is totally green). do you notice the waveform itself visually is not in sync with the animation? you can post screenshots not showing your composition window, just the timeline and the keyframes. obscure what you need to so we can try to examine what is wrong.

              • 4. Re: AE 2017 Bug - Time Remapping
                angelodc Level 1

                You're right, AE 2015 was removed. But when I look under the CC App, previous versions doesn't include AE. That's odd. Am i missing something?. (I've included a screenshot of CC app.)

                Screen Shot 2016-12-01 at 11.32.09 AM.png

                It's definitely not a preview issue. When I render out (instead of preview) the 2017 version, the bad time-remapping still shows up.

                • 5. Re: AE 2017 Bug - Time Remapping
                  angelodc Level 1

                  Update: A coworker showed me how to download the previous version of After Effects (2015).

                  Good news: When I open the project up in 2015, it works fine (therefore I'll continue using 2015 on this project.)

                  Bad news: When I open the project up in 2017, the time remapping is messed up.

                  • 6. Re: AE 2017 Bug - Time Remapping
                    Roei Tzoref Adobe Community Professional

                    Update: A coworker showed me how to download the previous version of After Effects (2015).

                    interesting. so where was it?

                     

                    Good news: When I open the project up in 2015, it works fine (therefore I'll continue using 2015 on this project.)

                    Bad news: When I open the project up in 2017, the time remapping is messed up.

                    Hold on! is there a jpeg sequence mixed in there???

                    • 7. Re: AE 2017 Bug - Time Remapping
                      angelodc Level 1

                      It was under the Find Additional apps tab, and at the bottom there was an option for View Previous Versions. (I've included a screen shot so you can see what i mean.)

                       

                      Screen Shot 2016-12-01 at 12.11.10 PM.png

                       

                      Nope, there is NOT "a jpeg sequence mixed in there", however there I did use screen recordings made with QuickTime Player (Version 10.4)

                      • 8. Re: AE 2017 Bug - Time Remapping
                        Roei Tzoref Adobe Community Professional

                        thanks for the screenshots.  if you got the time and can reproduce this bug with another project, I would like to take a look at it. I don't have Time remapping problems with cc2017 vs c2015. are the keyframes different? does the video speed up or slowdown? thanks for sharing the problem, this may become useful later.

                        • 9. Re: AE 2017 Bug - Time Remapping
                          angelodc Level 1

                          I did as you recommended. I successfully reproduced the bug. I've uploaded the test to creative cloud: http://adobe.ly/2gqECDM

                           

                          Let me explain what I did to execute the test.

                          1) I created a screen recording using Quicktime. (I saved the file as "screen_recording")

                          2) Using AE2015, i time-remapped the file. (I saved the file as "2015_time_remap.aep")

                          3) I opened the AE2015 file in 2017. Low and behold the time remap was different!!! (I saved the file as "2017_time_remap.aep")

                          • 10. Re: AE 2017 Bug - Time Remapping
                            Roei Tzoref Adobe Community Professional

                            thanks for taking the time. ok I see where the problems is. it seems the footage you recorded has a weird frame rate. I got it by using VLC player which is a free software that is more than just a reliable video player. notice the weird frame rate: 56.17

                            in Ae it get's interpreted one way in CC2015 and another in CC2017 and actually CC2017 is in the right because it is trying to play the video in the frame rate of 60 which will make it 5 seconds and 44 frames.

                            and not like previous version that does interpret it at 56.17 but says it's 60fps and the video is now 6 seconds and 7 frames (as it should be)

                            so what you can do is in CC2017 change the interpret footage to the real frame rate (right click on the footage-interpret footage) and insert the correct frame rate

                            now it will interpret correctly

                             

                            this is a workaround, the real solution would be to record in a video capture software that can encode the video in the exact specified frame rate, and not give this weird frame rate.

                            • 11. Re: AE 2017 Bug - Time Remapping
                              angelodc Level 1

                              I did it just as you said! I converted the screen capture files to the proper frame rate and my client's project went back to normal. Thanks so much! I really appreciate your help!

                              • 12. Re: AE 2017 Bug - Time Remapping
                                Roei Tzoref Adobe Community Professional

                                Great! thanks for the challenge and for hanging in there.