5 Replies Latest reply on Dec 5, 2016 7:46 PM by A+R

    Lightroom 6.7 permissions

    A+R

      I have just recently downloaded vers 6.7 of lightroom. previously been running old version of PS cs 6 and lightroom ver 5.4

      decided to upgrade both versions to latest version. this happened this week.

      lightroom 6.7 has been working for a couple of days - but when I started it up this morning it seems that something has happened to the exe file which I cannot work out.

      to start with the blue Lightoom icon that displays next the the exe file in explorer has been replaced with some funny symbol. This symbol still appears against the other Light room modules, like Develop, export, import etc.

      when I try to execute the lightroom program I get the ""Windows cannot execute the specified device, path , or file. You may not have the appropriate permissions to access them.""

      I have checked the windows permissions on this exe file and they all appear in order.

      I am set up as administrator on this system. Plus I created a new windows account with admin rights and tried that as well, but same issue appears.

      I have looked at various threads similar to this in the knowledge base and I cannot find any thing that is exactly similar to this issue.

      Lighroom does not even come up with a splash screen, so I do not even get the message "repair to continue" as displayed in one of the threads. I tried to find the folders as described in another solution , ""User\library\preferences"", but these folders do not exist on my system

      I am running Windows 10

      This machine is set up purely to run Lightroom and photoshop and nothing else.

      I shut the system down as usual last night but this morning lightroom is dead.

      I looked at the script file to restore permissions as documented in another thread and this appears to be a Mac thing.

       

      In addition Lightroom ver 5.4 is still on my system and is running just fine.

       

      SO I am stumped.

      My issue is why did this happen

       

      I am after suggestions if you could assist.

       

      Al

        • 1. Re: Lightroom 6.7 permissions
          JimHess Adobe Community Professional & MVP

          Check the permissions on the folders that contain your images. Also check the permissions on the folder that contains your Lightroom catalog..

          • 2. Re: Lightroom 6.7 permissions
            A+R Level 1

            Jim thanks for your prompt response.

            Yes I just went and checked the permissions on the new catalogs that are produced with LR 6.7. previous cat were vers 5

            yes they both have the same read write access permissions.

            Also checked the photo directories as well.

            bear in mind system is set up for optimum performance with catelogs on one drive and images on another.

            Checked permissions from top to bottom of the drives just to be sure.

            ANother observation is that the error message as stated above when I execute lightroom, comes pretty well instantaneously. as If the program has not even opened or looked at any thing.

            • 3. Re: Lightroom 6.7 permissions
              A+R Level 1

              Still having file security issues with both photoshop and lightroom. I reinstalled both of them the other day, and theinstall process would only work if I was in admin mode.

              now when I try to execute either lightroom or photoshop, they will only come up if I open them in admin mode.

              both the directories of lightroom and photoshop have limited access defined in the acl's. plus all of the files in them have limited access in their security settings.

              every thing only works if I open in admin mode.

              I have installed previous versions of lightroom and photoshop on the same machine with no issues.

              so I am after hints or solutions as to why this install has taken such a twist in stalling these products with limited windows file settings.

              the security sessions of both are set up so that only admin can execute them.

              any suggestions

               

              Note running windows 10 on PC. Lightroom standalone 6.7 and photoshop cs6.

              • 4. Re: Lightroom 6.7 permissions
                JimHess Adobe Community Professional & MVP

                I'm not sure what to suggest. I seem to recall that right after I switched to Windows 10 I got that message. If I remember correctly, it was a permissions issue with the Pictures folder which is where  the Lightroom catalog is created by default. Other than that, I have no idea what to suggest.

                • 5. Re: Lightroom 6.7 permissions
                  A+R Level 1

                  thanks jim - I am still picking up this prickly issue every morning to try to straighten it out. it looks like a local setting of some type - but have not cracked as of yet. my fall back is to run in admin mode.