1 Reply Latest reply on Dec 4, 2016 1:57 PM by janweir

    Nook Glowlight Plus

    MissKittyJ

      I use my nook for reading public library books.  The last two weeks problem arose:  i cannot open the library books in my files in the nook; I get an error message that the book cannot be opened.  Tried everything including returning the nook I had and replacing it with a new one today.  In file manager I can see nook and open my files and side load the library books in the file manager from documents/digital editions to nook. However when I try to open the book in nook, I get an error message.  A few times when I downloaded a book from the library the window that shows adobe digital editions as th default program did not even show up.  Tried everything:  authorized and de-authorized the computer. the device (nook), deleted all library books, reinstalled latest versions of adobe digital editions and overdrive media nothing worked.  Won't I be able to use the nook to check out library books any longer?

        • 1. Re: Nook Glowlight Plus
          janweir

          I've had several versions of the Nook reader.  Bought the very first one, bought the Nook Glow Light and about 6 months ago, bought the Nook Glow Light Plus.  The software for the first two versions were very user friendly and it was very easy to download library books (Adobe Digital Editions) and the corresponding .epub files.  However, the Nook Glow Light Plus - what a pain.  The Nook is not automatically recognized by the ADE and so you have to "show the file in Explorer" and then basically copy/paste the .epub file over to the Nook Glow Light Plus.  OK, I've done this successfully for 6 months and all of a sudden, this week, even though I can see the .epub file format on my Glow Light Plus (using a file explorer), when I try to open it on my Nook, I get the message "loan token update failed."  I made sure that my version of the software for ADE was up to date (it is at version 3.0) and than I had both my ADE on my laptop and my Nook Plus authorized (it is).  Was on Nook CHAT for 30 minutes and they finally gave up and told me to call Nook tech support.  Was on the phone for 20 minutes and finally, they said that Nook is "working on this problem" and that they are aware that this is an issue and that "as we speak, Nook is working on a solution."  However, no solution right now.  Grrrrrrrrrrrrrrrrrrrr.