1 Reply Latest reply on Dec 3, 2016 1:27 PM by vangroover

    Problem using plugin that requires apple-ios >= 10.0.0

    kschaijk

      When building for iOS, one of my plugins is skipped with the following error message (using cli-6.4.0):

       

      Fetching plugin "https://github.com/katzer/cordova-plugin-local-notifications.git" via git clone

      Using shallow clone

      Repository "https://github.com/katzer/cordova-plugin-local-notifications.git" checked out to git ref "ios10" at "fdf8470".

      Installing "de.appplant.cordova.plugin.local-notification" at "0.8.5-dev" for ios

      Plugin doesn't support this project's apple-ios version. apple-ios: 9.1.0, failed version requirement: >=10.0.0

      Skipping 'de.appplant.cordova.plugin.local-notification' for ios

       

      How can I configure PGB to use apple-ios version 10.0.0 or higher? When using the following config option:

       

      <preference name="deployment-target" value="10.0" />

       

      the build fails with the error message:

       

      ld: -ios_version_min argument is missing period as second character

       

      * In case someone has a local notification plugin that's compatible with iOS 10 and working with PGB please let me know.