8 Replies Latest reply on Dec 6, 2016 3:38 AM by Just Shoot Me

    My external hard drives do not show up in the Library Module.

    Eagle Eye David

      Lightroom's Library Mod does not show my external drives at all.  It does on Import, but not in general.  I wish to move files from my computers hard drive to an external, and know I need to do this thru Lightroom.  I am on a new computer, and this is the first I have needed to do this since changing computers.
      Mack Book Pro, with a 1TB hard drive.  Using Lightning cable.  The drives show up in finder.  They show up in Lightroom's Library Mod when clicking Import.
      In the past, they have always shown in the library general Folders Section.

       

      What am I missing?

        • 1. Re: My external hard drives do not show up in the Library Module.
          Just Shoot Me Adobe Community Professional

          LR is not a File Manager. The only drives and folders that show up in the Library module are the ones you have already imported images from.

           

          Use the File Manager for your OS to copy the images over to the external drive then in LR use the Update Folder location feature to point LR to the new location.

           

          I suggest you keep the same folder structure on the external as you have on your internal drive. Not drive name or drive letter but if all your images are now on drive X in your Pictures folder and then other Subfolders create a folder called Pictures on the external then copy over all the folders that are under the Pictures folder on your internal drive.

           

          Updating the Folder Location in Lightroom « Julieanne Kost's Blog

          • 2. Re: My external hard drives do not show up in the Library Module.
            Eagle Eye David Level 1

            Okay, I'll give that a try... I just know those question marks are going to pop up... thus the "Update folder Location" should fix that.
            Thank you.

            • 3. Re: My external hard drives do not show up in the Library Module.
              Just Shoot Me Adobe Community Professional

              That is why I said to COPY the file over not Move them. POnce you have them copied and reconnected in LR you can Delete the originals that are on your internal drive.

               

              99.99999% of the time I never Move files. I first copy them and when I am sure they are copied correctly I delete the originals.

              Had some problems in the past with moving files and some getting lost. Never want to go through that again.

              • 4. Re: My external hard drives do not show up in the Library Module.
                JimHess Adobe Community Professional & MVP

                Just to reinforce what JSM has said, it really isn't a good idea to try to move files around using Lightroom. It's very easy to make a mistake, and sometimes all the images don't get moved. It's best to COPY those images using File Manager or Finder. Then you can start Lightroom and still have access your images while you update the folder location. Once you have pointed Lightroom to the images in their new location and have verified that everything is connected as it should be you can safely delete the images in the original location.

                • 5. Re: My external hard drives do not show up in the Library Module.
                  Eagle Eye David Level 1

                  Jim, I'm talking about moving around 15,000 images in 30 or so files.  In the past I have be able to just pull the file down to the file in my external, they are copied, then I can delete the original.
                  I made the mistake of doing what everyone is telling me and it took forever.  I am assuming it is easy, and can be done by each file?
                  If I had to do image by image, I would not be thrilled.

                   

                  I still do not understand why the externals do not show up in the library now, when they always have in the past?  What am I doing wrong?

                  • 6. Re: My external hard drives do not show up in the Library Module.
                    Eagle Eye David Level 1

                    Actually, I did not have to delete them because they were moved.

                    • 7. Re: My external hard drives do not show up in the Library Module.
                      ManiacJoe Adobe Community Professional

                      Eagle Eye David wrote:

                       

                      Jim, I'm talking about moving around 15,000 images in 30 or so files. In the past I have be able to just pull the file down to the file in my external, they are copied, then I can delete the original.
                      I made the mistake of doing what everyone is telling me and it took forever. I am assuming it is easy, and can be done by each file?
                      If I had to do image by image, I would not be thrilled.

                       

                      I still do not understand why the externals do not show up in the library now, when they always have in the past? What am I doing wrong?

                      Using Finder or Explorer, copy (drag n drop) the desired top-most folder from your internal drive to your external drive.

                      Then in Lightroom, go to the Folders panel in the Library, right-click on the top-most folder that you copied, select "update folder location", navigate to your external drive. LR will update all the files and folders that you moved.

                       

                      Doing the actual file copy outside of LR is both faster and safer.

                       

                      The external drives to not show up because they are not referenced by any imported images. LR is not a file browser. It only shows you stuff about imported images.

                      • 8. Re: My external hard drives do not show up in the Library Module.
                        Just Shoot Me Adobe Community Professional

                        Eagle Eye David wrote:

                         

                        Jim, I'm talking about moving around 15,000 images in 30 or so files. In the past I have be able to just pull the file down to the file in my external, they are copied, then I can delete the original.
                        I made the mistake of doing what everyone is telling me and it took forever. I am assuming it is easy, and can be done by each file?
                        If I had to do image by image, I would not be thrilled.

                         

                        I still do not understand why the externals do not show up in the library now, when they always have in the past? What am I doing wrong?

                        In your first statement you  said "In the past I was able to pull files down to the files in my external". Do you mean FOLDER instead of File. Please you need to start using the correct terms. Folders are not Files and Files are not folders.

                         

                        The reason your external drive doesn't show up is because you have never imported any images from it. LR is NOT a File Manager program. It is a Database program. No drives show up in the Folders section of the Library module unless you have imported images from that drive previously. If you have in the past imported images from that external drive (or moved folder and files to it and reconnected them in LR) it could be because you don't have the option turned on to Show Parent Folder. But even then the only folder on that external drive that will show are ones you have previously imported images from. LR is not a File Manager program. The only place in LR that all drives and all folders will show up is in the Import dialog window.