7 Replies Latest reply on Dec 6, 2016 8:02 AM by Adilson Carneiro

    build crosswalk error

    Adilson Carneiro

      Hello, When compiling my project using crosswalk <plugin name = "cordova-plugin-crosswalk-webview" spec = "~ 1.3.1" source = "npm" /> this error occurred.

       

      Build Date: 2016-12-06 12:42:43 +0000
      --------------------------------------------------------------------------------
      PLUGIN OUTPUT
      --------------------------------------------------------------------------------
      Fetching plugin "cordova-plugin-dialogs@~1.3.0" via npm
      Installing "cordova-plugin-dialogs" at "1.3.0" for android
      Fetching plugin "cordova-plugin-splashscreen@~4.0.0" via npm
      Installing "cordova-plugin-splashscreen" at "4.0.0" for android
      Fetching plugin "cordova-plugin-vibration@~2.1.2" via npm
      Installing "cordova-plugin-vibration" at "2.1.2" for android
      Fetching plugin "cordova-plugin-device@~1.1.3" via npm
      Installing "cordova-plugin-device" at "1.1.3" for android
      Fetching plugin "cordova-plugin-network-information@~1.3.0" via npm
      Installing "cordova-plugin-network-information" at "1.3.0" for android
      Fetching plugin "phonegap-plugin-push-deprecated" via npm
      Installing "phonegap-plugin-push-deprecated" at "2.5.0-pgb-1" for android
      Fetching plugin "cordova-plugin-inappbrowser@~1.5.0" via npm
      Installing "cordova-plugin-inappbrowser" at "1.5.0" for android
      Fetching plugin "cordova-plugin-geolocation@~2.4.0" via npm
      Installing "cordova-plugin-geolocation" at "2.4.0" for android
      Fetching plugin "cordova-plugin-compat" via npm
      Installing "cordova-plugin-compat" at "1.1.0" for android
      Fetching plugin "cordova-plugin-x-toast" via npm
      Installing "cordova-plugin-x-toast" at "2.5.2" for android
      Fetching plugin "cordova-plugin-barcodescanner" via npm
      Installing "cordova-plugin-barcodescanner" at "0.7.0" for android
      Fetching plugin "cordova-plugin-media@~2.4.0" via npm
      Installing "cordova-plugin-media" at "2.4.0" for android
      Fetching plugin "cordova-plugin-file" via npm
      Installing "cordova-plugin-file" at "4.3.0" for android
      Dependent plugin "cordova-plugin-compat" already installed on android.
      
      The Android Persistent storage location now defaults to "Internal". Please check this plugins README to see if you application needs any changes in its config.xml.
      
      If this is a new application no changes are required.
      
      If this is an update to an existing application that did not specify an "AndroidPersistentFileLocation" you may need to add:
      
        "<preference name="AndroidPersistentFileLocation" value="Compatibility" />"
      
      to config.xml in order for the application to find previously stored files.
      
         
      Dependent plugin "cordova-plugin-compat" already installed on android.
      Fetching plugin "cordova-plugin-crosswalk-webview@~1.3.1" via npm
      Installing "cordova-plugin-crosswalk-webview" at "1.3.1" for android
      --------------------------------------------------------------------------------
      COMPILE OUTPUT
      --------------------------------------------------------------------------------
      Configuration on demand is an incubating feature.
      embedded
      org.xwalk:org.xwalk.core:22
      Incremental java compilation is an incubating feature.
      
      FAILURE: Build failed with an exception.
      
      * What went wrong:
      A problem occurred configuring root project 'project'.
      > Could not resolve all dependencies for configuration ':_armv7DebugCompile'.
        > Could not find org.xwalk:org.xwalk.core:22.
        Searched in the following locations:
        https://repo1.maven.org/maven2/org/xwalk/org.xwalk.core/22/org.xwalk.core-22.pom
        https://repo1.maven.org/maven2/org/xwalk/org.xwalk.core/22/org.xwalk.core-22.jar
        https://jcenter.bintray.com/org/xwalk/org.xwalk.core/22/org.xwalk.core-22.pom
        https://jcenter.bintray.com/org/xwalk/org.xwalk.core/22/org.xwalk.core-22.jar
        https://download.01.org/crosswalk/releases/crosswalk/android/maven2/org/xwalk/org.xwalk.core/22/org.xwalk.core-22.pom
        https://download.01.org/crosswalk/releases/crosswalk/android/maven2/org/xwalk/org.xwalk.core/22/org.xwalk.core-22.jar
        file:/android-sdk/extras/android/m2repository/org/xwalk/org.xwalk.core/22/org.xwalk.core-22.pom
        file:/android-sdk/extras/android/m2repository/org/xwalk/org.xwalk.core/22/org.xwalk.core-22.jar
        file:/android-sdk/extras/google/m2repository/org/xwalk/org.xwalk.core/22/org.xwalk.core-22.pom
        file:/android-sdk/extras/google/m2repository/org/xwalk/org.xwalk.core/22/org.xwalk.core-22.jar
        Required by:
        :project:unspecified
      
      * Try:
      Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
      
      BUILD FAILED
      
      Total time: 3.071 secs
      Error: /project/gradlew: Command failed with exit code 1 Error output:
      FAILURE: Build failed with an exception.
      
      * What went wrong:
      A problem occurred configuring root project 'project'.
      > Could not resolve all dependencies for configuration ':_armv7DebugCompile'.
        > Could not find org.xwalk:org.xwalk.core:22.
        Searched in the following locations:
        https://repo1.maven.org/maven2/org/xwalk/org.xwalk.core/22/org.xwalk.core-22.pom
        https://repo1.maven.org/maven2/org/xwalk/org.xwalk.core/22/org.xwalk.core-22.jar
        https://jcenter.bintray.com/org/xwalk/org.xwalk.core/22/org.xwalk.core-22.pom
        https://jcenter.bintray.com/org/xwalk/org.xwalk.core/22/org.xwalk.core-22.jar
        https://download.01.org/crosswalk/releases/crosswalk/android/maven2/org/xwalk/org.xwalk.core/22/org.xwalk.core-22.pom
        https://download.01.org/crosswalk/releases/crosswalk/android/maven2/org/xwalk/org.xwalk.core/22/org.xwalk.core-22.jar
        file:/android-sdk/extras/android/m2repository/org/xwalk/org.xwalk.core/22/org.xwalk.core-22.pom
        file:/android-sdk/extras/android/m2repository/org/xwalk/org.xwalk.core/22/org.xwalk.core-22.jar
        file:/android-sdk/extras/google/m2repository/org/xwalk/org.xwalk.core/22/org.xwalk.core-22.pom
        file:/android-sdk/extras/google/m2repository/org/xwalk/org.xwalk.core/22/org.xwalk.core-22.jar
        Required by:
        :project:unspecified
      
      * Try:
      Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
        at ChildProcess.whenDone (/project/cordova/node_modules/cordova-common/src/superspawn.js:169:23)
        at emitTwo (events.js:106:13)
        at ChildProcess.emit (events.js:191:7)
        at maybeClose (internal/child_process.js:877:16)
        at Process.ChildProcess._handle.onexit (internal/child_process.js:226:5)
      
        • 1. Re: build crosswalk error
          VectorP Level 4

          That version is ancient.

          Since 1.3.1, more than 10 new releases have been published at npm. Please try the latest version (simply remove any version/spec attribute from the plugin element).

          • 2. Re: build crosswalk error
            Adilson Carneiro Level 1

            hi,

             

            I did what you mentored. It compiles but does not let the apk install on the phone. I was struck by this message in the log:

            Installing "cordova-plugin-crosswalk-webview" at "2.2.0" for android

            Plugin doesn't support this project's cordova-android version. cordova-android: 5.2.1, failed version requirement: >=6

            Skipping 'cordova-plugin-crosswalk-webview' for android

             

            complete log:

             

            Build Date: 2016-12-06 14:42:03 +0000

            --------------------------------------------------------------------------------

            PLUGIN OUTPUT

            --------------------------------------------------------------------------------

            Fetching plugin "cordova-plugin-dialogs@~1.3.0" via npm

            Installing "cordova-plugin-dialogs" at "1.3.0" for android

            Fetching plugin "cordova-plugin-splashscreen@~4.0.0" via npm

            Installing "cordova-plugin-splashscreen" at "4.0.0" for android

            Fetching plugin "cordova-plugin-vibration@~2.1.2" via npm

            Installing "cordova-plugin-vibration" at "2.1.2" for android

            Fetching plugin "cordova-plugin-device@~1.1.3" via npm

            Installing "cordova-plugin-device" at "1.1.3" for android

            Fetching plugin "cordova-plugin-network-information@~1.3.0" via npm

            Installing "cordova-plugin-network-information" at "1.3.0" for android

            Fetching plugin "phonegap-plugin-push-deprecated" via npm

            Installing "phonegap-plugin-push-deprecated" at "2.5.0-pgb-1" for android

            Fetching plugin "cordova-plugin-inappbrowser@~1.5.0" via npm

            Installing "cordova-plugin-inappbrowser" at "1.5.0" for android

            Fetching plugin "cordova-plugin-geolocation@~2.4.0" via npm

            Installing "cordova-plugin-geolocation" at "2.4.0" for android

            Fetching plugin "cordova-plugin-compat" via npm

            Installing "cordova-plugin-compat" at "1.1.0" for android

            Fetching plugin "cordova-plugin-x-toast" via npm

            Installing "cordova-plugin-x-toast" at "2.5.2" for android

            Fetching plugin "cordova-plugin-barcodescanner" via npm

            Installing "cordova-plugin-barcodescanner" at "0.7.0" for android

            Fetching plugin "cordova-plugin-media@~2.4.0" via npm

            Installing "cordova-plugin-media" at "2.4.0" for android

            Fetching plugin "cordova-plugin-file" via npm

            Installing "cordova-plugin-file" at "4.3.0" for android

            Dependent plugin "cordova-plugin-compat" already installed on android.

             

            The Android Persistent storage location now defaults to "Internal". Please check this plugins README to see if you application needs any changes in its config.xml.

             

            If this is a new application no changes are required.

             

            If this is an update to an existing application that did not specify an "AndroidPersistentFileLocation" you may need to add:

             

              "<preference name="AndroidPersistentFileLocation" value="Compatibility" />"

             

            to config.xml in order for the application to find previously stored files.

             

              

            Dependent plugin "cordova-plugin-compat" already installed on android.

            Fetching plugin "cordova-plugin-crosswalk-webview" via npm

            Installing "cordova-plugin-crosswalk-webview" at "2.2.0" for android

            Plugin doesn't support this project's cordova-android version. cordova-android: 5.2.1, failed version requirement: >=6

            Skipping 'cordova-plugin-crosswalk-webview' for android

            --------------------------------------------------------------------------------

            COMPILE OUTPUT

            --------------------------------------------------------------------------------

            Configuration on demand is an incubating feature.

            Incremental java compilation is an incubating feature.

            :preBuild UP-TO-DATE

            :preDebugBuild UP-TO-DATE

            :checkDebugManifest

            :CordovaLib:preBuild UP-TO-DATE

            :CordovaLib:preDebugBuild UP-TO-DATE

            :CordovaLib:compileDebugNdk UP-TO-DATE

            :CordovaLib:compileLint

            :CordovaLib:copyDebugLint UP-TO-DATE

            :CordovaLib:mergeDebugProguardFiles

            :CordovaLib:packageDebugRenderscript UP-TO-DATE

            :CordovaLib:checkDebugManifest

            :CordovaLib:prepareDebugDependencies

            :CordovaLib:compileDebugRenderscript

            :CordovaLib:generateDebugResValues

            :CordovaLib:generateDebugResources

            :CordovaLib:packageDebugResources

            :CordovaLib:compileDebugAidl

            :CordovaLib:generateDebugBuildConfig

            :CordovaLib:mergeDebugShaders

            :CordovaLib:compileDebugShaders

            :CordovaLib:generateDebugAssets

            :CordovaLib:mergeDebugAssets

            :CordovaLib:processDebugManifest

            :CordovaLib:processDebugResources

            :CordovaLib:generateDebugSources

            :CordovaLib:incrementalDebugJavaCompilationSafeguard

            :CordovaLib:compileDebugJavaWithJavac

            :CordovaLib:compileDebugJavaWithJavac - is not incremental (e.g. outputs have changed, no previous execution, etc.).

            Note: Some input files use or override a deprecated API.

            Note: Recompile with -Xlint:deprecation for details.

            :CordovaLib:processDebugJavaRes UP-TO-DATE

            :CordovaLib:transformResourcesWithMergeJavaResForDebug

            :CordovaLib:transformClassesAndResourcesWithSyncLibJarsForDebug

            :CordovaLib:mergeDebugJniLibFolders

            :CordovaLib:transformNative_libsWithMergeJniLibsForDebug

            :CordovaLib:transformNative_libsWithSyncJniLibsForDebug

            :CordovaLib:bundleDebug

            :prepareProjectCordovaLibUnspecifiedDebugLibrary

            :prepareDebugDependencies

            :compileDebugAidl

            :compileDebugRenderscript

            :generateDebugBuildConfig

            :mergeDebugShaders

            :compileDebugShaders

            :generateDebugAssets

            :mergeDebugAssets

            :generateDebugResValues

            :generateDebugResources

            :mergeDebugResources

            :processDebugManifest

            :processDebugResources

            :generateDebugSources

            :incrementalDebugJavaCompilationSafeguard

            :compileDebugJavaWithJavac

            :compileDebugJavaWithJavac - is not incremental (e.g. outputs have changed, no previous execution, etc.).

            Note: Some input files use or override a deprecated API.

            Note: Recompile with -Xlint:deprecation for details.

            Note: /project/src/org/apache/cordova/file/AssetFilesystem.java uses unchecked or unsafe operations.

            Note: Recompile with -Xlint:unchecked for details.

            :compileDebugNdk UP-TO-DATE

            :compileDebugSources

            :prePackageMarkerForDebug

            :transformClassesWithDexForDebug

            Merged dex #1 (86 defs/108.5KiB)

            Merged dex #2 (958 defs/977.4KiB)

            Merged dex #3 (343 defs/552.5KiB)

            Merged dex #4 (131 defs/163.8KiB)

            Merged dex #5 (4 defs/18.7KiB)

            Result is 1522 defs/2240.9KiB. Took 0.0s

            :mergeDebugJniLibFolders

            :transformNative_libsWithMergeJniLibsForDebug

            :processDebugJavaRes UP-TO-DATE

            :transformResourcesWithMergeJavaResForDebug

            :validateDebugSigning

            :packageDebug

            :zipalignDebug

            :assembleDebug

            :cdvBuildDebug

             

            BUILD SUCCESSFUL

             

            Total time: 5.218 secs

            Built the following apk(s):

            /project/build/outputs/apk/project-debug.apk

            • 3. Re: build crosswalk error
              VectorP Level 4

              Did you review the release notes in the plugin's docs?

              Perhaps you should try a previous release (like 1.7.0) or use another plugin, like

              cordova-plugin-crosswalk-webview-pgb-adapt

              • 4. Re: build crosswalk error
                Adilson Carneiro Level 1

                Hello I tried this plugin cordova-plugin-crosswalk-webview-pgb-adapt and I set my config.xml to <gap: plugin name = "cordova-plugin-crosswalk-webview-pgb-adapt" source = "npm" version = "1.4 .0-dev-5 "/> But returns this error (cli-5.2.0) as docs plugin:

                 

                Build Date: 2016-12-06 15:37:59 +0000

                --------------------------------------------------------------------------------

                PLUGIN OUTPUT

                --------------------------------------------------------------------------------

                Fetching plugin "cordova-plugin-crosswalk-webview-pgb-adapt@1.4.0-dev-5" via npm

                Installing "com.berthni.crosswalk.engine" at "1.4.0" for android

                Using this version of Cordova with older version of cordova-android is being deprecated. Consider upgrading to cordova-android@5.0.0 or newer.

                Fetching plugin "cordova-plugin-dialogs@~1.3.0" via npm

                Installing "cordova-plugin-dialogs" at "1.3.0" for android

                Using this version of Cordova with older version of cordova-android is being deprecated. Consider upgrading to cordova-android@5.0.0 or newer.

                Fetching plugin "cordova-plugin-splashscreen@~4.0.0" via npm

                Installing "cordova-plugin-splashscreen" at "4.0.0" for android

                Using this version of Cordova with older version of cordova-android is being deprecated. Consider upgrading to cordova-android@5.0.0 or newer.

                Fetching plugin "cordova-plugin-vibration@~2.1.2" via npm

                Installing "cordova-plugin-vibration" at "2.1.2" for android

                Using this version of Cordova with older version of cordova-android is being deprecated. Consider upgrading to cordova-android@5.0.0 or newer.

                Fetching plugin "cordova-plugin-device@~1.1.3" via npm

                Installing "cordova-plugin-device" at "1.1.3" for android

                Using this version of Cordova with older version of cordova-android is being deprecated. Consider upgrading to cordova-android@5.0.0 or newer.

                Fetching plugin "cordova-plugin-network-information@~1.3.0" via npm

                Installing "cordova-plugin-network-information" at "1.3.0" for android

                Using this version of Cordova with older version of cordova-android is being deprecated. Consider upgrading to cordova-android@5.0.0 or newer.

                Fetching plugin "phonegap-plugin-push-deprecated" via npm

                Installing "phonegap-plugin-push-deprecated" at "2.5.0-pgb-1" for android

                Using this version of Cordova with older version of cordova-android is being deprecated. Consider upgrading to cordova-android@5.0.0 or newer.

                Fetching plugin "cordova-plugin-inappbrowser@~1.5.0" via npm

                Installing "cordova-plugin-inappbrowser" at "1.5.0" for android

                Using this version of Cordova with older version of cordova-android is being deprecated. Consider upgrading to cordova-android@5.0.0 or newer.

                Fetching plugin "cordova-plugin-geolocation@~2.4.0" via npm

                Installing "cordova-plugin-geolocation" at "2.4.0" for android

                Fetching plugin "cordova-plugin-compat" via npm

                Installing "cordova-plugin-compat" at "1.1.0" for android

                Using this version of Cordova with older version of cordova-android is being deprecated. Consider upgrading to cordova-android@5.0.0 or newer.

                Fetching plugin "cordova-plugin-x-toast" via npm

                Installing "cordova-plugin-x-toast" at "2.5.2" for android

                Using this version of Cordova with older version of cordova-android is being deprecated. Consider upgrading to cordova-android@5.0.0 or newer.

                Fetching plugin "cordova-plugin-barcodescanner" via npm

                Installing "cordova-plugin-barcodescanner" at "0.7.0" for android

                Using this version of Cordova with older version of cordova-android is being deprecated. Consider upgrading to cordova-android@5.0.0 or newer.

                Fetching plugin "cordova-plugin-media@~2.4.0" via npm

                Installing "cordova-plugin-media" at "2.4.0" for android

                Fetching plugin "cordova-plugin-file" via npm

                Installing "cordova-plugin-file" at "4.3.0" for android

                Dependent plugin "cordova-plugin-compat" already installed on android.

                Using this version of Cordova with older version of cordova-android is being deprecated. Consider upgrading to cordova-android@5.0.0 or newer.

                 

                The Android Persistent storage location now defaults to "Internal". Please check this plugins README to see if you application needs any changes in its config.xml.

                 

                If this is a new application no changes are required.

                 

                If this is an update to an existing application that did not specify an "AndroidPersistentFileLocation" you may need to add:

                 

                  "<preference name="AndroidPersistentFileLocation" value="Compatibility" />"

                 

                to config.xml in order for the application to find previously stored files.

                 

                  

                Dependent plugin "cordova-plugin-compat" already installed on android.

                --------------------------------------------------------------------------------

                COMPILE OUTPUT

                --------------------------------------------------------------------------------

                Build option --'' not recognized (ignoring).

                Running: /project/gradlew cdvBuildDebug -b /project/build.gradle -Dorg.gradle.daemon=true -PcdvBuildMultipleApks=false -PcdvVersionCode=2

                Configuration on demand is an incubating feature.

                :preBuild

                :compileDebugNdk

                :preDebugBuild

                :checkDebugManifest

                :CordovaLib:compileLint

                :CordovaLib:copyDebugLint UP-TO-DATE

                :CordovaLib:mergeDebugProguardFiles

                :CordovaLib:preBuild

                :CordovaLib:preDebugBuild

                :CordovaLib:checkDebugManifest

                :CordovaLib:prepareDebugDependencies

                :CordovaLib:compileDebugAidl

                :CordovaLib:compileDebugRenderscript

                :CordovaLib:generateDebugBuildConfig

                :CordovaLib:generateDebugAssets UP-TO-DATE

                :CordovaLib:mergeDebugAssets

                :CordovaLib:generateDebugResValues

                :CordovaLib:generateDebugResources

                :CordovaLib:packageDebugResources

                :CordovaLib:processDebugManifest

                :CordovaLib:processDebugResources

                :CordovaLib:generateDebugSources

                :CordovaLib:compileDebugJavaNote: Some input files use or override a deprecated API.

                Note: Recompile with -Xlint:deprecation for details.

                 

                :CordovaLib:processDebugJavaRes UP-TO-DATE

                :CordovaLib:packageDebugJar

                :CordovaLib:compileDebugNdk

                :CordovaLib:packageDebugJniLibs UP-TO-DATE

                :CordovaLib:packageDebugLocalJar UP-TO-DATE

                :CordovaLib:packageDebugRenderscript UP-TO-DATE

                :CordovaLib:bundleDebug

                :com.berthni.crosswalk.engine:xwalk_core_library:compileLint

                :com.berthni.crosswalk.engine:xwalk_core_library:copyDebugLint UP-TO-DATE

                :com.berthni.crosswalk.engine:xwalk_core_library:mergeDebugProguardFiles

                :com.berthni.crosswalk.engine:xwalk_core_library:preBuild

                :com.berthni.crosswalk.engine:xwalk_core_library:preDebugBuild

                :com.berthni.crosswalk.engine:xwalk_core_library:checkDebugManifest

                :com.berthni.crosswalk.engine:xwalk_core_library:preDebugTestBuild

                :com.berthni.crosswalk.engine:xwalk_core_library:prepareProjectCordovaLibUnspecifiedDebugL ibrary

                :com.berthni.crosswalk.engine:xwalk_core_library:prepareDebugDependencies

                :com.berthni.crosswalk.engine:xwalk_core_library:compileDebugAidl

                :com.berthni.crosswalk.engine:xwalk_core_library:compileDebugRenderscript

                :com.berthni.crosswalk.engine:xwalk_core_library:generateDebugBuildConfig

                :com.berthni.crosswalk.engine:xwalk_core_library:generateDebugAssets UP-TO-DATE

                :com.berthni.crosswalk.engine:xwalk_core_library:mergeDebugAssets

                :com.berthni.crosswalk.engine:xwalk_core_library:generateDebugResValues

                :com.berthni.crosswalk.engine:xwalk_core_library:generateDebugResources

                :com.berthni.crosswalk.engine:xwalk_core_library:mergeDebugResources

                :com.berthni.crosswalk.engine:xwalk_core_library:processDebugManifest

                :com.berthni.crosswalk.engine:xwalk_core_library:processDebugResources

                :com.berthni.crosswalk.engine:xwalk_core_library:generateDebugSources

                :com.berthni.crosswalk.engine:xwalk_core_library:compileDebugJava

                :com.berthni.crosswalk.engine:xwalk_core_library:processDebugJavaRes

                :com.berthni.crosswalk.engine:xwalk_core_library:packageDebugJar

                :com.berthni.crosswalk.engine:xwalk_core_library:compileDebugNdk

                :com.berthni.crosswalk.engine:xwalk_core_library:packageDebugJniLibs

                :com.berthni.crosswalk.engine:xwalk_core_library:packageDebugLocalJar

                :com.berthni.crosswalk.engine:xwalk_core_library:packageDebugRenderscript UP-TO-DATE

                :com.berthni.crosswalk.engine:xwalk_core_library:packageDebugResources

                :com.berthni.crosswalk.engine:xwalk_core_library:bundleDebug

                :prepareProjectComBerthniCrosswalkEngineXwalk_core_libraryUnspecifiedDebugLibrary

                :prepareProjectCordovaLibUnspecifiedDebugLibrary

                :prepareDebugDependencies

                :compileDebugAidl

                :compileDebugRenderscript

                :generateDebugBuildConfig

                :generateDebugAssets UP-TO-DATE

                :mergeDebugAssets

                :generateDebugResValues

                :generateDebugResources

                :mergeDebugResources

                :processDebugManifest

                :processDebugResourceswarning: string 'menu_settings' has no default translation.

                Warning: AndroidManifest.xml already defines debuggable (in http://schemas.android.com/apk/res/android); using existing value in manifest.

                 

                :generateDebugSources

                :compileDebugJavaNote: Some input files use or override a deprecated API.

                Note: Recompile with -Xlint:deprecation for details.

                Note: /project/src/org/apache/cordova/file/AssetFilesystem.java uses unchecked or unsafe operations.

                Note: Recompile with -Xlint:unchecked for details.

                 

                :preDexDebug

                :dexDebug

                UNEXPECTED TOP-LEVEL EXCEPTION:

                com.android.dex.DexException: Multiple dex files define Landroid/support/annotation/AnimRes;

                at com.android.dx.merge.DexMerger.readSortableTypes(DexMerger.java:591)

                at com.android.dx.merge.DexMerger.getSortedTypes(DexMerger.java:546)

                at com.android.dx.merge.DexMerger.mergeClassDefs(DexMerger.java:528)

                at com.android.dx.merge.DexMerger.mergeDexes(DexMerger.java:164)

                at com.android.dx.merge.DexMerger.merge(DexMerger.java:188)

                at com.android.dx.command.dexer.Main.mergeLibraryDexBuffers(Main.java:504)

                at com.android.dx.command.dexer.Main.runMonoDex(Main.java:334)

                at com.android.dx.command.dexer.Main.run(Main.java:277)

                at com.android.dx.command.dexer.Main.main(Main.java:245)

                at com.android.dx.command.Main.main(Main.java:106)

                 

                FAILED

                 

                FAILURE: Build failed with an exception.

                 

                * What went wrong:

                Execution failed for task ':dexDebug'.

                > com.android.ide.common.internal.LoggedErrorException: Failed to run command:

                  /android-sdk/build-tools/24.0.1/dx --dex --no-optimize --output /project/build/intermediates/dex/debug --input-list=/project/build/intermediates/tmp/dex/debug/inputList.txt

                  Error Code:

                  2

                  Output:

                 

                  UNEXPECTED TOP-LEVEL EXCEPTION:

                  com.android.dex.DexException: Multiple dex files define Landroid/support/annotation/AnimRes;

                  at com.android.dx.merge.DexMerger.readSortableTypes(DexMerger.java:591)

                  at com.android.dx.merge.DexMerger.getSortedTypes(DexMerger.java:546)

                  at com.android.dx.merge.DexMerger.mergeClassDefs(DexMerger.java:528)

                  at com.android.dx.merge.DexMerger.mergeDexes(DexMerger.java:164)

                  at com.android.dx.merge.DexMerger.merge(DexMerger.java:188)

                  at com.android.dx.command.dexer.Main.mergeLibraryDexBuffers(Main.java:504)

                  at com.android.dx.command.dexer.Main.runMonoDex(Main.java:334)

                  at com.android.dx.command.dexer.Main.run(Main.java:277)

                  at com.android.dx.command.dexer.Main.main(Main.java:245)

                  at com.android.dx.command.Main.main(Main.java:106)

                 

                 

                 

                * Try:

                Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

                 

                BUILD FAILED

                 

                Total time: 44.181 secs

                 

                /project/cordova/node_modules/q/q.js:126

                  throw e;

                  ^

                Error code 1 for command: /project/gradlew with args: cdvBuildDebug,-b,/project/build.gradle,-Dorg.gradle.daemon=true,-PcdvBuildMultipleApks=fa lse,-PcdvVersionCode=2

                • 5. Re: build crosswalk error
                  Adilson Carneiro Level 1

                  hi,

                  build use <gap:plugin name="cordova-plugin-crosswalk-webview-pgb-adapt" source="npm" version="1.4.0-dev-10"/> sdkminversion14+ in work

                   

                  Tanks

                  • 6. Re: build crosswalk error
                    VectorP Level 4

                    But....why do you insist on using older versions of both that plgin and PGB? Why not use the latest versions of both?

                    • 7. Re: build crosswalk error
                      Adilson Carneiro Level 1

                      The newer versions of both gave problem