6 Replies Latest reply on Dec 11, 2016 8:41 PM by Amebr

    RoboHelp 2015 lag issues

    paaron46

      Ever since upgrading from RH 11 to RH 2015 we've been experiencing awful lag issues. Everything from opening topics to typing has a second or two lag which is unbearable after a while, and is costing us valuable man hours.

       

      I contacted Adobe customer support. The representative took over my computer and tried to fix the issue himself. He couldn't. He said it was an issue with my project, but couldn't tell me what the issue actually was. There were no such lag issues in RH11, so I'm wondering how this can be the fault of my project and not of RH 2015.

       

      I've seen other discussion posts about RH 2015 lag issues, but the only response I've seen to those is to run the project locally on your machine. I am doing this and I still get the lag issues constantly. How can I fix this lag?

       

      Edition: RH 2015

      Version: 12.0.4.460

       

      Project size: 200+ topics

       

      Windows 10 Pro

      RAM: 16GB

      i7-6650U CPU @ 2.20 GHz

       

      TortoiseSVN 1.9.4 - Used to version our help and keep it synced with the software, but the project is checked out locally to my machine. When I update the project in RH 2015 I then update the main project through SVN. (Again, we used this same exact setup with RH11 and it worked like a charm.)

       

      Thank you for your time.

        • 1. Re: RoboHelp 2015 lag issues
          Captiv8r Adobe Community Professional & MVP

          Hi there

           

          Oh how fun. Don't you love troubleshooting?

           

          I think I I were in your shoes, I'd begin by simply closing the project you are in and creating a new empty project. Add a few topics. See if the lag still exists after playing with it for a while. If so, you know it's got something to do with RoboHelp and your setup. And if there seems to be no lag, my own suspicion is something to do with the fact source control is in the mix. At that point, further troubleshooting would be in order.

           

          Cheers... Rick

          • 2. Re: RoboHelp 2015 lag issues
            Peter Grainge Adobe Community Professional (Moderator)

            ... or try one of the sample projects that ship with RoboHelp.

            • 3. Re: RoboHelp 2015 lag issues
              paaron46 Level 1

              There is no lag when creating or working on a new blank project. The Adobe support person tried that when they worked on my computer. Sorry, should've mentioned that.

               

              We do not have the option of not using source control (SVN) with our help so I hope that's not the issue. If that's the case why would RH11 work great with SVN and RH 2015 does not?

               

              What other troubleshooting can I try?

              • 4. Re: RoboHelp 2015 lag issues
                Karin_Albrecht Level 1

                Hi!

                I'm not a  specialist for your question, but I might be able to provide some more reference information. I'm using RH 2015 with TortoiseSVN on Windows 7, 8 GB RAM, also with several large projects (size +1000 topics). I don't have any lag issues, neither when opening a project nor when typing or saving. So I don't think it's a general problem of using version control and RH 2015. More likely your problem is caused by a mix of several issues.

                 

                Kind regards
                Karin

                • 5. Re: RoboHelp 2015 lag issues
                  paaron46 Level 1

                  Any other ideas on how to troubleshoot this situation?

                  • 6. Re: RoboHelp 2015 lag issues
                    Amebr Level 4

                    I assume that you didn't also change operating system, etc when you upgraded to RH2015? If you did, perhaps you need to check you have 32-/64-bit versions of (sorry, mental blank) the api/dll/thingy that RH uses to talk to SVN. ( Just a thought experiment, so may be completely irrelevant. The thing I'm thinking of is specifically for TFS - the MSSCCI Provider, but possibly there is a similar thing for SVN).

                     

                    Or anther thing to check is your antivirus. Many years ago I had problems with very slow check-in/out and it turned out to be the antivirus scanning every file multiple times. The solution was to make sure the AV only scanned once, rather than on both actions - I think it was only scan on check-out, but possibly vice versa.