2 Replies Latest reply on Jan 10, 2009 10:16 AM by Newsgroup_User

    several datagrid issues

      I have a Datagrid that is populated dynamically. For each item there are 5 columns all having the same width. I set the grid to be wide enough to display one set of 5 columns, one of the columns uses a numeric stepper as an itemRenderer/Editor. The problem occurs on scroll the stepper still refers to the first set of columns. How can I get so the steppers are reassigned to the new data on scroll of the Grid? Any help as always is greatly appreciated.
        • 1. Re: several datagrid issues
          rtalton Level 4
          Understand that the item renderers (your numeric stepper) are constantly recycled as rows move off-screen. So don't refer to them to get at your data. It just doesn't work.
          Refer to the dataprovider index instead to gte at the data.
          • 2. Re: several datagrid issues
            Level 7

            "Mush15" <webforumsuser@macromedia.com> wrote in message
            news:gk7mbd$7bl$1@forums.macromedia.com...
            >I have a Datagrid that is populated dynamically. For each item there are 5
            > columns all having the same width. I set the grid to be wide enough to
            > display
            > one set of 5 columns, one of the columns uses a numeric stepper as an
            > itemRenderer/Editor. The problem occurs on scroll the stepper still refers
            > to
            > the first set of columns. How can I get so the steppers are reassigned to
            > the
            > new data on scroll of the Grid? Any help as always is greatly appreciated.
            >

            http://www.magnoliamultimedia.com/flex_examples/Amys_Flex_FAQ.pdf
            Q2