3 Replies Latest reply on Aug 20, 2017 6:48 PM by sheilabriggs

    E_ACT_NOT_READY and cannot deauthorize

    JameyTh Level 1

      I am running Mac OS X 10.11.6.  I was using DE 1.7 until Overdrive's update seemed to force me to upgrade to ADE 4.5.

       

      Since that point, every ACSM gets the same error "E_ACT_NOT_READY".

       

      1. I tried to erase authorization, but I get the same error that it failed and please try again later.  Very polite, that. 
      2. Authorize is grayed out and authorization information does show that my account is linked.  Adobe.com login shows that the account is correct.
      3. Finally, I found the solution of deleting the activation.dat file but inside of my USERS/LIBRARY/APPLICATIONSUPPORT/ADOBE and there is no DigitalEditions folder at all.  Much less, .dat to delete.

      I removed all traces of Digital Editions (app and folder deleted, all shortcuts gone gone gone).  Downloaded and reinstalled and still the same errors.

       

      Any new ideas?

        • 1. Re: E_ACT_NOT_READY and cannot deauthorize
          JameyTh Level 1

          Chat won't help because it is not a paid product issue, I guess.  I posted here and received nothing from the forum and tried multiple different solutions on OS X 10.11 and 10.12.  No dice.

           

          Downgrade to v3.0 and suddenly it all works.  Sloppy, sloppy coding is the only explanation I have and I wish there were options for other DRM software that I could choose from.  Tell me that Overdrive is paying Adobe for this level of un-support... disgusting.

           

          (For any future download issues, I had to dig on the Net to find the link for v3.0 here - Download | Adobe Digital Editions Home ).

          1 person found this helpful
          • 2. Re: E_ACT_NOT_READY and cannot deauthorize
            emilyck22

            So glad I found your thread! I was going crazy and couldn't get any of my books to open with the e_act_not_ready error and I tried deleting, redownloading, doing the deauthorization, etc and nothing worked. I just downloaded the 3.0 version and now I can finally open library books again! Now to re-reserve all the ones I lost due to this issue. Thank you!!

            • 3. Re: E_ACT_NOT_READY and cannot deauthorize
              sheilabriggs Level 1

              Solving the "E_ACT_NOT_READY" error code can be more complicated than the standard solution of de-authorizing and then re-authorizing your computer. When I tried this, I was not allowed to de-authorize my computer and was told to try again later. But later, even days later, did not work. The only way to de-authorize my computer was to manually erase the "activation.dat" file for Adobe Digital Editions. To do this on a Mac, complete the following steps:

              1. 1.Go to  your User Home Folder (the one with the house icon).
              2. Choose the Library folder. If you are unable to follow this or the next steps, it means you have hidden library folders and files. To access these folders and files, under the "Go" menu in Finder, choose "Go to Folder" (Shift-Cmd-G). Type in the following command, "~/Library" and now everything will be visible.

              3 Choose the sub-folder Application Support and within this folder find the sub-folder Adobe.

              1. In the Adobe folder search for and open the Digital Editions sub-folder. At this point, you will see at the bottom of the Finder window, something very similar to the following location path: Macintosh HD>Users>User name>Library>Applications Support>Adobe>Digital Editions.
              2. In the Digital Editions folder find the file "activation.dat" and move it to the trash.
              3. Start up or return to the Adobe Digital Editions app and in the Help menu choose "Authorize Computer."

               

              After doing this I was able to open ebooks that I had loaned from a library without changing any further parameters for my account. If you still have problems, I suggest the further steps:

              • Erase older versions of Adobe Digital Editions. I had already done that in previous unsuccessful attempts to solve the problem.
              • Check your ID. I use my Adobe ID to gain access to several library collections of ebooks. You may find that the publisher of your ebook requires a different and specific ID. It seems that you can have different IDs for different ebook sources and you can set this up when you authorize your computer
              • Check in the Digital Editions folder of your Mac Library that you have only one copy of your activation ID. This is is a long filename of hexadecimal numbers (ordinary numbers plus the six letters a,b,c,d,e,f). Check that it matches the date and time of the "activation.dat" file. This filename is the same as the same as the hexadecimal number that shows up as the "urn:uuid" when you choose "Authorization Information" in the Help menu of Adobe Digital Editions. I think that an erased or corrupted version of this file was why Adobe DIgital Editions stopped opening my ebooks in the first place.