3 Replies Latest reply on Dec 13, 2016 4:49 PM by MicheleAlise

    Indesign Cell Styles Don't Show Border Settings

    MicheleAlise Level 1

      I'd like to use tables more in my documents, but there are certain challenges I keep running into.

      One is the inability to apply borders when I want them, and not when I don't.

       

      For example, I created a table style called borderless, all borders turned off, this works fine.

      Next, I created cell a style called "border bottom" by un-checking the blue border lines for all vertical and top lines.

      But..I am still getting the vertical borders, and when I go in to verify my settings in cell style options dialogue, it does not show what I have chosen, but it's as if I had not turned on any settings at all - it's a big blank.

       

      It's the same with any of the table styles I've created, please see screenshot. I cannot see what is being applied as the dialogue doesn't seem to remember my settings.

       

      Is this a glitch? This seems to be contrary to any other style settings in InDesign.

       

      Cell Styles Dialogue InDesign.png

        • 1. Re: Indesign Cell Styles Don't Show Border Settings
          BarbBinder Adobe Community Professional

          No, tables are just plain confusing until you figure them out. Once, you do, they are amazing.

           

          How did you set up the Borderless Table style? Did you select the table and turn off on the lines in Cell Options (which is cell level) or did you set the Row and Column pattern to alternative every other row, with all settings at 0 in Table Options (table level).

           

          If you did the former, I think you are up against overrides. To assign the BottomBorder, instead of clicking, Right click the style and choose Apply style and remove overrides.

          • 2. Re: Indesign Cell Styles Don't Show Border Settings
            BarbBinder Adobe Community Professional

            To visually see how I would set it up:

             

            The table styles has all the rules turned off—in Table Setup, Row Strokes and Column Strokes.

            InDesign CCss_029.png

            InDesign CCss_026.png

            InDesign CCss_027.png

            The cell style has just to bottom blue line selected (rest are grey), then set up the rule.

            InDesign CCss_025.png

            Once they are both in place, click in a cell to assign the cell style with the bottom border.

            InDesign CCss_028.png

             

            Overrides can be a total PITA. Remove them—from the table in advance or plan on removing them as you assign the cell styles. To clear all overrides in a given table, select it and Alt/Opt click on [Basic Table] at the top of the Table Styles panel, and on [None} at the top of the cell styles panel. Then assign the table style, and if you are not using nested cell styles, assign those manually.

            • 3. Re: Indesign Cell Styles Don't Show Border Settings
              MicheleAlise Level 1

              Thank you @BarbBinder! I was a bit dubious, but I went through everything in triplicate and I'm 90% happy with my table now. I  understand a whole lot better now.

               

              One difficulty I see with INDD's tables is that you can't see when overrides exist, or what the override is, unlike with paragraph styles that show the plus sign and the overrides in parenthesis. Also, I would never have guessed that one has to engage the strokes in the table style to simply nullify them.

               

              I appreciate the time you took to help me out - you're a gem!