13 Replies Latest reply on Dec 15, 2016 3:11 PM by darrenjansen

    Table of Contents' Sub-Items Don't Expand after Translation

    darrenjansen Level 1

      So in short I have RoboHelp HTML 9.0.1.262. I'm generating WebHelp with new translations but the translated table of contents doesn't work.

       

      So here are the details. I tried generating the source (English) webhelp with the language set to the target language (French). No problem. I opened the project with Help & Manual 2 GO as my server, and everything looked fine. The TOC worked fine.

       

      Then I copied over the translated documents (only .htm, .hhc, and .hhk files, no others) from my translation tool (memoQ) into the RoboHelp project folders, replacing the English files. I then recompiled the webhelp, but the TOC sub-items will no longer expand. The Index and Search still work fine.

       

      I tried some experiments. I tried replacing only the .htm files with the newly translated files but not replacing the .hhc and .hhk files. That worked fine. The content all appeared as French except for the TOC, and the TOC worked as normal. The only problem was that it gave me a warning in RoboHelp that said, "Configuration Error." Other than that everything seemed to work fine.

       

      I tried another experiment. I tried compiling the parent project with some of the child projects in English and one of them in French. When I opened this parent project, the French child project's TOC didn't work. However, after I clicked on an English project's TOC and opened a sub-item, the French TOC suddenly started working. Even though it was working, it still felt a little buggy because sometimes the sub-items didn't want to close again or you had to click twice on them to open them.

       

      I have not manually altered any .js files. I also used Beyond Compare to compare the source .hhc and .hhk files with the translated files. As best as I can tell, none of the xml code had been corrupted in the translation process. Only the strings were changed. The xml tags were all identical.

       

      What is causing this TOC bug? Any ideas? How can I fix this?

       

      (P.S. I'm viewing the output in Chrome. I don't think that has anything to do with it.)