2 Replies Latest reply on Dec 19, 2016 7:05 AM by thomasj54347878

    [Acrobat/inDesign] Search results depending on frame position in inDesign

    thomasj54347878 Level 1

      Hello everyone,


      I have some strange behaviour of the search in a PDF file.


      I have a new, empty inDesign document with a text frame, containing the article no. "U6-060Z", on one layer and a rectangle frame on a background layer, placed on the master page. For the letter "U" I have set a spacing value of 1400 so that I have a gap between the first two characters.


      After the PDF export I search the PDF file for the string "U6-060Z". I don't enter a space character after "U". Result: I dont' find anything. If I enter a space in the search I find it.


      If I move the frame to to a third, foreground layer and export it, I find the article no. entering the same search string without a space character.

      I can also find the article no. if I place the frame on the background layer but on the same page as the frame - so no placement on the master page.


      I have this behaviour on two different computers, both using inDesign CS v. 8.0 / 8.0.1. Things which don't matter, because I already tried several different options: Frame color, frame size, frame orientation, font, export settings, "contact" of frame and text, ID files (problem in new empty documents as well as in different already existing ones)


      So, what is it I want to achieve?

      I want to place the frame in the background layer on the master page and the text on a separate layer above, having a spacing for the first letter. In the PDF file I want to find the article no. by entering it in the PDF search without a space character between U and 6.


      Can someone reproduce this behaviour? What is the problem? Any solution?


      Could it be a problem with the object tags? Because the rectangle frame on the masterpage becomes always a "Form-XObject: Path" in the PDF. (As this thread says this is a fact and can't be changed: forums.adobe.com/thread/1627883 ) Changing it to a artifact has the result that I find the article no. without space.


      I hope I explained my problem understandable. If not, in the following link I zipped a short desktop video showing what I did as well as the inDesign and PDF file: WeTransfer