0 Replies Latest reply on May 18, 2006 12:57 PM by cfoster

    cfdocument font size problem

      I'm running into an apparent bug using cfdocument to generate a PDF. I'm grouping query data with cfoutput to create an inventory report by department and site, and I'm using inline styles to control font family, size, etc. Each department is grouped into its own cfdocumentsection (with its own header and footer), and within each department section the inventory results are grouped by site. An alternate version groups first by site, then by department. There are filtering options to run a full inventory report or subsets based on inventory age.

      Everything displays properly until I run a larger report. A full inventory query returns about 2500 records, and while most of the report still displays properly, the font size gets much larger for certain departments. It appears the departments affected are typically those with a larger number of query results, but not always. I first noticed this problem a few weeks ago, and after much troubleshooting I tried switching from points to picas ... for some reason that took care of the problem at the time. Today we've added another inventory type to the report which expanded the query results, and now the problem is back. I'm not using any exotic fonts (your basic "Arial, Helvetica, sans-serif"), and the font size is supposed to be .7pc.

      Has anyone else encountered this? Ideally I'd like some suggestions for workarounds, or at least some confirmation that this is a bug. Thank you!