2 Replies Latest reply on May 17, 2006 1:52 PM by joemacd

    Trouble creating text fields

    joemacd
      Flash 8 Pro

      Here's a good one:

      The only way I can create a text field is to:

      - Create one using Action Script, or
      - Copy an existing one on the stage and paste it as a new one.

      If I try to create a new one on the stage, it doesn't seem to be enabled.


      For clarity, I didn't have this problem yesterday. Yesterday, I created a number of text fields on the stage, and they all seem to work.

      Today, I follow the same path, the text field appears on the stage, but when I execute the app, the field just isn't there anymore.

      To test it, I used getDepth to find out of the fields were actually hidden somewhere. While the text fields I created yesterday all returned a depth, the new ones don't.

      If I copy one of yesterday's fields and rename it, it works fine.

      So this isn't a HUGE problem, but I'm worried about the possibility that I have to create a new field sometime, and I don't have an old one to copy.

      any ideas?

        • 1. Re: Trouble creating text fields
          Level 7

          "joemacd" <webforumsuser@macromedia.com> wrote in message
          news:e4fp7v$pp4$1@forums.macromedia.com...
          > Flash 8 Pro
          >
          > Here's a good one:
          >
          > The only way I can create a text field is to:
          >
          > - Create one using Action Script, or
          > - Copy an existing one on the stage and paste it as a new one.
          >
          > If I try to create a new one on the stage, it doesn't seem to be enabled.
          >
          >
          > For clarity, I didn't have this problem yesterday. Yesterday, I created a
          > number of text fields on the stage, and they all seem to work.
          >
          > Today, I follow the same path, the text field appears on the stage, but
          > when I
          > execute the app, the field just isn't there anymore.
          >
          > To test it, I used getDepth to find out of the fields were actually hidden
          > somewhere. While the text fields I created yesterday all returned a depth,
          > the
          > new ones don't.
          >
          > If I copy one of yesterday's fields and rename it, it works fine.
          >
          > So this isn't a HUGE problem, but I'm worried about the possibility that I
          > have to create a new field sometime, and I don't have an old one to copy.
          >
          > any ideas?
          >
          >
          >


          Is this dynamic text fields or static text?