3 Replies Latest reply on May 19, 2006 8:37 AM by wallaceandgromit

    Shared Assets command not available for users

    wallaceandgromit
      I have searched all day for a reason why my non-admin type users in Contribute 3 are unable to insert images via the Insert --> Shared Assets option. The command is greyed out. Their role permissions have "allow unrestricted editing" set so I can't figure out why they'd be barred from this shared asset feature. I REALLY don't want to give these users full admin priveledges. They are getting tired to re-running new connection keys everytime I randomly try a new setting. Any help would be greatly appreciated.
        • 1. Shared Assets command not available for users
          hillaryT
          In the "Shared Assets" setting, you have added assets? and is the box at the bottom checked to use the list for all roles?

          If all else fails, and it's still not working, I've found that the connection key is sometimes corrupt and the only way to fix the issue is to NOT replace the connection key, but have the client remove the connection key first and then open the new connection key. HTH
          • 2. Re: Shared Assets command not available for users
            wallaceandgromit Level 1
            Yes, it is set to affect all roles and some images have been added to the Shared Assets.

            Removing the previous connection key is an interesting idea. Didn't think of that. May have to give it a try.

            For now I sent them another connection key after changing the Editing setting to prevent users from inserting images (except for shared assets) to see if they gain access that way.
            • 3. Shared Assets command not available for users
              wallaceandgromit Level 1
              It appears that by disabling a user's ability to insert images (except for Shared Assets) is the way to go. As an admin I was spoiled as I can insert images any which way I choose (insert --> images, cut-and-paste, and Shared Assets). As a regular user it is one or the other, either Shared Assets or Insert-->Images, not both.

              So in order to give users the ability to access Shared Assets, you must go in and set "Allow unrestricted editing" then check the "Prevent users from inserting images" option. After they activate the connection key it then only allows them to insert images in the Shared Asset feature.