4 Replies Latest reply on Dec 28, 2016 7:56 AM by Johnny Quest

    flash player installing problem

    ah.2000

      flash player always vulnerable and its updates don't run!!!!!!!!!

      I try to download it from below links but nothing was happened the file downloaded and didn't run with any way (double click, right click then open or run as... or extract and found no exe file to run). I try that on two windows OS. I use Windows XP Sp2

       

      1-http://get.adobe.com/flashplayer/?promoid=JZEFT (1.14mb file and didn't run).

      2-https://helpx.adobe.com/flash-player/kb/installation-problems-flash-player-windows.html then https://fpdownload.macromedia.com/pub/flashplayer/latest/help/install_flash_player.exe  (19.4mb file and didn't run).

      3-http://download.macromedia.com/pub/flashplayer/latest/help/install_flash_player.exe (19.4mb file and didn't run).

       

      I want to use any working version without updates  even if it was old version.

       

      Note: I face this issue from a few months by the first link above in my question, and I solved it by searching in adobe site and found the second link, but the files from it have stopped working for one month, I search again and found the third link. Now All link has files that don't run, So what?!!!!!.

        • 2. Re: flash player installing problem
          Johnny Quest Level 1

          The 1.x MB bootstrap installer will not work due to https dependencies (item 8 - https://helpx.adobe.com/flash-player/kb/installation-problems-flash-player-windows.html). I have two win xp sp2 machines I tried running both NPAPI (the one you tried) and the the ActiveX standalone installer (install_flash_player_ax.exe 18.9MB so similar ) got the same thing as you (no window) on one machine but  got the "Adobe Flash Payer 24.0 Installer" window on the other (same exe file).  Had a quick look at dll dependency nothing was flagged as missing (did see difference in gdiplus.dll).  Without any error message it is hard to know what is causing this, it is not writing any info to c:\WINDOWS\system32\Macromed\Flash\FlashInstall.log so I doubt it is loading.

           

          So the same exe file works on one machine but not the other. I checked and I  find no log file updates (FlashInstall.log) or any evidence that the exe file is loading. There is nothing in event viewer. ah.2000 do you see any log file changes?  I am trying suggestion - https://forums.adobe.com/message/8842166#8842166

           

          @support Is there a dot-net dependency ? Anyone know if there is anyway to get debug info from the installer?

          • 3. Re: flash player installing problem
            ah.2000 Level 1

            Sorry I don't know about dll files, and about "FlashInstall.log" I deleted all files related to flash player from my PC "manually" after uninstalling it within trying to solve the problem and also deleted the all installer files that downloaded before from all links. And I can't trace windows logs because I tried to install it many times with several versions old and new,"Of course the old had installed but Firefox automatically deactivate them".

            I tried to found an alternative add-one of flash player or a solution from Mozilla.

             

            On the other windows OS "also XP Sp2"  that I have tried on before I don't find any new thing in the "FlashInstall.log".

            • 4. Re: flash player installing problem
              Johnny Quest Level 1

              ah.2000 ok if you can install an old version of flash player that firefox deactivates that's good that should imply flashutil*.exe  (*=part of name varies depending on version) is installed and working.  I fixed my one following https://forums.adobe.com/message/8842166#8842166 advice which I mentioned before I turned on the flash background update (which I normally have disabled) .  Open control panel classic view then flash player and turn on "Allow Adobe..." :

              flash_seetings_darth.png

              I then ran flashutil*.exe in flash folder this triggered a 18.9MB exe download that ran and did its update. Closed all my running programs and recheck control panel again and showed I was on v24.x  for NPAPI and ActiveX.

               

              I just have 2 separate issues with v24.x

              1. did not detect the running portable firefox (not surprised) so will need to manual replace NPAPI dll

              2. ActiveX version performance is poor for (old Celeron 2.62 Ghz/736MB/ASUS P4SP-MX / SiS 651 32MB) the old flash 10.x ActiveX barely kept up with a 560Kb/s media stream going at 90% CPU usage. V24.x runs 100% CPU and audio is not in sync.This is one of the few tasks it needed to do now it unacceptable. I will need to try an older version.