1 Reply Latest reply on Dec 27, 2016 12:08 AM by VectorP

    I have an error

    spentam87047349

      My app id is 2291214

       

      I got a Error - One of your plugins required the gradle android build tool to built

       

      How I can solve this issue reply asap?

       

      My config file has following plugins and app data

       

      <preference name="phonegap-version"           value="3.7.0" />          <!-- all: current version of PhoneGap -->

          <preference name="orientation"                value="portrait" />        <!-- all: default means both landscape and portrait are enabled -->

          <preference name="target-device"              value="handset" />      <!-- all: possible values handset, tablet, or universal -->

          <preference name="fullscreen"                 value="false" />           <!-- all: hides the status bar at the top of the screen -->

          <preference name="webviewbounce"              value="true" />           <!-- ios: control whether the screen 'bounces' when scrolled beyond the top -->

          <preference name="prerendered-icon"           value="true" />           <!-- ios: if icon is prerendered, iOS will not apply it's gloss to the app's icon on the user's home screen -->

          <preference name="stay-in-webview"            value="false" />          <!-- ios: external links should open in the default browser, 'true' would use the webview the app lives in -->

          <preference name="ios-statusbarstyle"         value="black-opaque" />   <!-- ios: black-translucent will appear black because the PhoneGap webview doesn't go beneath the status bar -->

          <preference name="detect-data-types"          value="true" />           <!-- ios: controls whether data types (such as phone no. and dates) are automatically turned into links by the system -->

          <preference name="exit-on-suspend"            value="false" />          <!-- ios: if set to true, app will terminate when home button is pressed -->

          <preference name="show-splash-screen-spinner" value="true" />           <!-- ios: if set to false, the spinner won't appear on the splash screen during app loading -->

          <preference name="auto-hide-splash-screen"    value="true" />           <!-- ios: if set to false, the splash screen must be hidden using a JavaScript API -->

          <preference name="disable-cursor"             value="false" />          <!-- blackberry: prevents a mouse-icon/cursor from being displayed on the app -->

          <preference name="android-minSdkVersion"      value="7" />              <!-- android: MIN SDK version supported on the target device. MAX version is blank by default. -->

          <preference name="android-installLocation"    value="auto" />           <!-- android: app install location. 'auto' will choose. 'internalOnly' is device memory. 'preferExternal' is SDCard. -->

           <preference name="DisallowOverscroll"        value="true"/>

            <preference name="android-build-tool" value="gradle" />

       

       

          <!-- Plugins -->

       

       

          <!-- Core plugins -->

              <plugin name="cordova-plugin-battery-status" spec="~1.2.2" />

        <plugin name="cordova-plugin-camera" spec="~2.3.1" />

              <plugin name="cordova-plugin-console" spec="~1.0.5" />

              <plugin name="cordova-plugin-contacts" spec="~2.2.1" />

              <plugin name="cordova-plugin-device" spec="~1.1.4" />

        <plugin name="cordova-plugin-device-motion" spec="~1.2.3" />

        <plugin name="cordova-plugin-device-orientation" spec="~1.0.5" />

              <plugin name="cordova-plugin-dialogs" spec="~1.3.1" />

        <plugin name="cordova-plugin-file" spec="~4.3.1" />

        <plugin name="cordova-plugin-file-transfer" spec="~1.6.1" />

        <plugin name="cordova-plugin-geolocation" spec="~2.4.1" />

        <plugin name="cordova-plugin-globalization" spec="~1.0.5" />

        <plugin name="cordova-plugin-inappbrowser" spec="~1.6.1" />

        <plugin name="cordova-plugin-media" spec="~2.4.1" />

        <plugin name="cordova-plugin-media-capture" spec="~1.4.1" />

        <plugin name="cordova-plugin-network-information" spec="~1.3.1" />

        <plugin name="cordova-plugin-splashscreen" spec="~4.0.1" />

        <plugin name="cordova-plugin-vibration" spec="~2.1.3" />

              <plugin name="cordova-plugin-statusbar" spec="~2.2.1" />

        <plugin name="cordova-plugin-whitelist" spec="~1.3.1" />

        • 1. Re: I have an error
          VectorP Level 4
          <preference name="phonegap-version"       value="3.7.0" /> 

          You most likely don't want this version, since it's ancient. Google won't accept such app in their PlayStore. You need to upgrade, preferable to the 'cli-6.x' versions.

           

            <plugin name="cordova-plugin-file" spec="~4.3.1" />

            <plugin name="cordova-plugin-file-transfer" spec="~1.6.1" />

          If you have the file-transfer plugin included, you don't need to include the file plugin anymore, since it's already included in the file-transfer plugin

           

          In order to find out which plugin requires the Gradle build, you could:

          a) check for more information in the Build's log, or

          b) read all documentation for each plugin, or

          c) remove each plugin one-by-one untile the error message disappears

          ...or you could simply add the Gradle build tool in the config.