1 Reply Latest reply on Dec 30, 2016 12:39 AM by 99jon

    LR6.8 update results in missing api-ms-win-crt-runtime.l1-1-0.dll

    JagDude

      Upgrading from LR6.7 to 6.8 on a 64-bit Windows7 PC resulted in a missing DLL.

       

      I saw the installer install Microsoft Visual C++ 2012 (Redistrubutable) as part of the upgrade.  When I tried to launch LR6.8, it gave me the error:

      api-ms-win-crt-runtime.l1-1-0.dll is missing from your computer.

       

      I found the missing DLLs and put them into the Windows System32 and 64 directories and rebooted.

       

      Now when I try to launch LR6.8, it says that "The procedure entry point for ucrtbase.terminate could not be located in the dynamic link library api-ms-win-crt-runtime-l1-1-0.dll."

       

      I've rolled back to LR6.0 (which launched) and then updated again to L6.8 using the "Check for Updates" feature, and I get the same error.

       

      Installing Microsoft Visual C++ 2015 (Redistributable) also produces the same "entry point" error.

       

      I have a Canon 5DMarkIV and I was in the middle of editing RAW files when I ran the update.  I need at least LR6.7 to read the 5DMarkIV files.

       

      I am running the standalone version of LR6 (not LRCC), so I can't use the Creative Cloud installers.

       

      Can someone please help me!  I either need to get my LR6.7 back or fix this DLL issue.  I'm not even sure at this point that rolling back to LR6.7 will work since something clobbered a DLL somewhere.  I'm not a PC guru, so I really don't know how to troubleshoot DLLs.     Also, I have a LOT of (old?) versions of Microsoft Visual C++ (2005, 2008, 2010, 2012, and 2015).  Do I need all of these? Can they be clobbering each other? 

       

      Thanks for any help!