2 Replies Latest reply on Feb 27, 2017 9:00 AM by rogerkmb

    Adobe Editions 4.5.3 does not start (System.Xml.XmlException)

    DeltaZuluCharlie Level 1

      On a Windows 10 Home Edition (64 bit) with latest patches as of Jan 3, 2017

       

      A previous Adobe Editions 4.5.2 is crashing immediately with the following in the event logs:

      Application: DigitalEditions.exe

      Framework Version: v4.0.30319

      Description: The process was terminated due to an unhandled exception.

      Exception Info: System.Xml.XmlException

       

      AND

      Faulting application name: DigitalEditions.exe, version: 4.5.2.0, time stamp: 0x57a3f6aa

      Faulting module name: KERNELBASE.dll, version: 10.0.14393.479, time stamp: 0x58256d37

      Exception code: 0xe0434352

      Fault offset: 0x000da832

      Faulting process id: 0x59f4

       

      Troubleshooting already taken:

      • Tried to run as administrator
      • Installed 4.5.3 over 4.5.2
        • 1. Re: Adobe Editions 4.5.3 does not start (System.Xml.XmlException)
          DeltaZuluCharlie Level 1

          Problem solved. It seems the user.config file became corrupted, it had quite a few null entries on the end and the XML wasn't complete, as in <xml> </xml>

           

          The file is located here: C:\Users\username\AppData\Local\Adobe_Systems_Incorporate\DigitalEditions.exe_Url_qyaa14c 3q2yckzgdtukp5ltfvp1pdpdu\2.0.0.0

           

          I deleted it and Adobe Editions started fine and recreated the file. I still have access to my DRM downloaded books.

           

          Hope this helps anyone.

          2 people found this helpful
          • 2. Re: Adobe Editions 4.5.3 does not start (System.Xml.XmlException)
            rogerkmb

            Thank you. I searched the web. I searched the forums. I found that several people were not able to open ADE after it had been working well, but nobody provided a solution. I finally found your post. It was relevant and it worked.  My problem with ADE happened like this: The program would open, but then would hang after plugging in my Kobo reader. Then I got get a blue screen. (I think they used to call it the blue screen of death) Windows 10 restarted by itself. The next time I tried to open ADE, I got the blue screen again, and the system restarted. After uninstalling ADE the system seemed to stabilize, I don't know whether uninstalling helped the blue screen problem, but I haven't gotten the blue screen since, even after I reinstalled ADE. But now ADE would not start. After a few attempts at uninstalling and reinstalling, and trying a few suggested solutions, it still would not start. Your solution was the only one that worked. Thanks again. By the way, I don't recall getting the  Windows 10 blue screen since I installed it in mid 2015. I suspect the problem was caused by trying using Apple software earlier that day.