9 Replies Latest reply on Jan 9, 2017 10:48 PM by krinas98558976

    My application is randomly crashing, most of the time when I am using camera or after usage of camera.  Application is developed using PhoneGap.

    krinas98558976

      Only clue that I got from console is:

       

      ConnectivityService: RemoteException caught trying to send a callback msg for NetworkRequest [ id=53, legacyType=-1, [ Capabilities: INTERNET&NOT_RESTRICTED&TRUSTED] ]

       

      Detail Log:

       

      12-27 13:22:37.441 10103-10103/? E/CAM_PhotoModule: mGraphView is null 12-27 13:22:37.444 10103-10103/? E/SoundPool: error loading /system/media/audio/ui/continuous_shot.ogg 12-27 13:22:37.531 25421-25599/? E/WifiStateMachine: handleMessage: E msg.what=131155 12-27 13:22:37.531 25421-25599/? E/WifiStateMachine: processMsg: ConnectedState 12-27 13:22:37.531 25421-25599/? E/WifiStateMachine: processMsg: L2ConnectedState 12-27 13:22:37.537 25421-25599/? E/WifiStateMachine: handleMessage: X 12-27 13:22:37.588 298-11848/? E/mm-camera-sensor: sensor_write_init_settings:291 OTP done 12-27 13:22:37.588 298-11848/? E/mm-camera-sensor: actuator_load_lib:351 name=dw9714_p8v12b, mode=camera 12-27 13:22:37.592 298-11848/? E/mm-camera-sensor: actuator_load_lib:351 name=dw9714_p8v12b, mode=camcorder 12-27 13:22:37.601 25176-32364/? E/mm-camera-intf: mm_camera_open: opened, break out while loop 12-27 13:22:37.618 25176-32364/? E/qomx_image_core: OMX_Init:94] Complete 2 12-27 13:22:37.619 25176-32364/? E/QCameraHWI_Mem: void qcamera::QCameraMemory::traceLogAllocStart(size_t, int, const char*):HeapMemsize 1048576 12-27 13:22:37.619 25176-32364/? E/QCameraHWI_Mem: void qcamera::QCameraMemory::traceLogAllocStart(size_t, int, const char*):Memsize 1048576 12-27 13:22:37.620 25176-32364/? E/QCameraHWI_Mem: void qcamera::QCameraMemory::traceLogAllocEnd(size_t) 1048576 12-27 13:22:37.620 25176-32364/? E/QCameraHWI_Mem: void qcamera::QCameraMemory::traceLogAllocEnd(size_t) 1048576 12-27 13:22:37.664 298-11881/? E/mm-camera: mct_pipeline_process_set:1594: Couldn't find stream 12-27 13:22:37.691 10103-10103/? E/CAM_PhotoModule: Width = 1280Height = 960 12-27 13:22:37.700 25176-11846/? E/mm-camera-intf: mm_stream_get_v4l2_fmt: Unknown fmt=99 12-27 13:22:37.703 298-11881/? E/mm-camera: isp_util_find_matched_existing_src_port#166: X

       

      I am wondering without direction in this issue. It would be great if somebody can point out reason or clue towards resolution. Please note that I have provided all permissions it is not relevant to permission.