2 Replies Latest reply on Apr 21, 2017 9:06 AM by dan-gra

    ?:0: attempt to index a nil value when trying to import an Aperture library

    beatk69109540

      I have just started to use Lightroom 2015.8 on an iMac with macOS 10.12.2. I have created a new catalog and tried to import an Aperture library with referenced master images (the master images are all in a folder inside my Pictures folder). However, immediately after starting the import operation, I get an error dialog telling me that there has been an internal error: "?:0: attempt to index a nil value". Nothing has been imported when I close the dialog.

       

      I've browsed the forum for this error and there is this thread which is for a different operation that also fails with this error. The suggested solution is to install an older version of Lightroom. I have tried it now with 2015.7 but the error still pops up. There is also this thread, where the proposed solution is to move the Aperture app to the desktop but this hasn't helped either.

       

      Any help will be appreciated!