0 Replies Latest reply on Jan 12, 2017 2:19 PM by kevinq19750741

    play services conflict

    kevinq19750741

      I am trying to get both cordova-plugin-geofence and cordova-plugin-fcm compiling on Phonegap Build, but it fails with:

       

      "Found com.google.android.gms:play-services-location:+, but version 9.2.0 is needed for the google-services plugin."

       

      I notice that the plugin.xml for geofence has the line:

       

      <framework src="com.google.android.gms:play-services-location:+" />

       

      so that's the issue.  I suppose one solution might be to copy the repository and change that line to:

       

      <framework src="com.google.android.gms:play-services-location:9.2.0" />

       

       

      but is there a way in the config.xml to override the framework requested in a plugin?

      or maybe some other magic?