11 Replies Latest reply on Jan 24, 2017 12:06 PM by ianj49859707

    The exported audio visualisation project looks different to the AE project.

    ianj49859707

      Hi all,

       

       

      Be amazing if anyone could help me...

       

       

      I'm following this tutorial:

       

       

      https://www.youtube.com/watch?v=liJf2v2CGdI&feature=youtu.be

       

       

       

      To make an audio visualisation. (An image that reacts to music).

       

       

      I'm using after effects CS6, everything is working fine, but when I come to render and export, the visualisation is completely flat.

       

      In other words, the AE project and the exported video are different.

       

      I've tried exporting with audio but can't seem to figure out what the problem is.

       

       

      Any help would be much appreciated.

       

       

      Ian,

        • 1. Re: The exported audio visualisation project looks different to the AE project.
          Szalam Adobe Community Professional & MVP

          What were your render settings? When you say "flat" do you mean the colors looked different or do you mean there was no animation?

          What, exact, version of CS6 are you running?

          What OS?

          1 person found this helpful
          • 2. Re: The exported audio visualisation project looks different to the AE project.
            Rick Gerard Adobe Community Professional & MVP

            My first thought after watching about 3 minutes of that tutorial is that it is a perfect example of a tutorial that doesn't teach you anything at all that is useful. The template is very poorly laid out and the hoops you have to jump through to get the project customized are very amateurish.

             

            Still, if you want to use these resources and you are very new to AE you need to learn about rendering and output to be successful. I suspect, because of the questions that you asked, that you are not that experienced and that you have not properly set up the audio to react with the effects plug-ins that are being used. Please give us more details and tell us exactly where your project falls apart. Some full size screenshots with the modified properties of the layers giving you problems revealed (press uu to do that). That's about the only way we can help you.

            1 person found this helpful
            • 3. Re: The exported audio visualisation project looks different to the AE project.
              ianj49859707 Level 1

              Hi Szalam,

               

              I realise flat wasn't the best choice of words...

               

              What I mean is the visualisation animates a tiny bit which I think it would do anyway if I hadn't attached the music, so it's basically in its default settings ignoring my added animation when exported. Whereas when I ran preview the visualisation animates completely and correctly.

               

              I'm running the 64 bit version of CS6 on Windows.

              • 4. Re: The exported audio visualisation project looks different to the AE project.
                Roei Tzoref Adobe Community Professional
                so it's basically in its default settings ignoring my added animation when exported. Whereas when I ran preview the visualisation animates completely and correctly.

                there is still missing information but two guesses come to mind.

                1. do you mean you are only seeing a small part of you animation instead of its whole length? if this is the case, check your Work Area:

                Ae defaults to render the Work area. if needed, you can stretch it by grabbing it by the handles. or use keyboard shortcut N to set and end point for the workarea

                 

                2. if you mean you see a visual in the preview that is missing in the final render, then one common mistake is to leave a layer as a "Guide Layer" it has an indication which is kind of a blue hashtag #:

                Guide layers do not render but can be previewed - their purpose is to serve as a references

                 

                 

                if this is neither of the examples shown above then please provide screenshots to illustrate how exactly is your render different from your animation.

                1 person found this helpful
                • 5. Re: The exported audio visualisation project looks different to the AE project.
                  ianj49859707 Level 1

                  1) Checked work area of the main composition and it's fully stretched out.

                   

                  2) I do mean I see a visual in the preview that is missing in the final render. I can't see the blue guide later preview anywhere.

                   

                  Something new is happening now, the main composition is is also no longer showing the animation. I have to go into a pre-comp to see it. But even if I render and export just the pre-comp I still can't see the visualisation movements in the final export.

                   

                  Some other things that might be worth mentioning:

                   

                  In my main composition it says "Proxy Enabled" and has a red bar, it wasn't doing this yesterday.

                   

                  When loading the project it says: "project contains 1 reference to a missing effect. Please install the following effect to restore this reference. ("Particular").

                   

                  Here are some images.

                   

                  This is what shows in my ran preview:

                   

                  ran preview.PNG

                   

                  Here is my final export:

                   

                  export.PNG

                   

                  (Ignore the logo) The problem is the wavelines are flat.

                   

                   

                  Thanks,

                  • 6. Re: The exported audio visualisation project looks different to the AE project.
                    Roei Tzoref Adobe Community Professional

                    the story unfolds even more...

                     

                    In my main composition it says "Proxy Enabled" and has a red bar, it wasn't doing this yesterday.

                    Proxy enabled - did you make this proxy? now I am confused, is this your project? proxies are rendered movies that are made in order to save processing time during renders. the default "best settings" is to render without the proxies. you can change that by going to the render settings in your render queue and change it.

                    change proxy use to - use all proxies

                    When loading the project it says: "project contains 1 reference to a missing effect. Please install the following effect to restore this reference. ("Particular").

                    it seems you have a missing plugin. the project uses this plugin in some way that may impact your render if you are actually rendering the layer that uses it. if you are seeing the preview as it should be, this should not matter since you are either not really using the layer that is using this effect.

                     

                    we are still guessing because it appears you have a messy project that you are not familiar with. if all you want is to render your preview and the preview is still fine in Ae, hopefully enabling proxies in your render should work for you without digging too much further.

                    • 7. Re: The exported audio visualisation project looks different to the AE project.
                      ianj49859707 Level 1

                      I didn’t make the proxy. My project is a template I downloaded.

                       

                      Here is a link to the tutorial and the template:

                      https://www.youtube.com/watch?v=liJf2v2CGdI&feature=youtu.be

                       

                      I tried opening the original download template and adding music to that as well and even that exports without the animation, completely different what I see in ran preview.

                       

                      Tried the enable proxies suggestions and that didn’t change the outcome.

                      • 8. Re: The exported audio visualisation project looks different to the AE project.
                        Roei Tzoref Adobe Community Professional

                        I suspect the answer to this problem might be even simpler then we thought:

                        by examining the templates (which look nice BTW) I see the template you are using -  "Rays of Light". there is room for user error by rendering the wrong composition. there is a composition named "Main Graph" which could be what you eventually rendered, instead of the main composition which is named _Main Composition.

                         

                        about the "particular missing" message you got before:

                        one layer require the plugin "particular" to have the full effect and you need to install it for this to happen. this has a minor impact to the visual outcome though.

                         

                        about the proxy message:

                        still not sure how it happened. the default template does not use any proxies so I suggest you open the original template project and start fresh.

                         

                        so make sure you are rendering the composition you are previewing. render the compsition called _Main Composition. if this was the case then here's an advice: I usually create a render folder in the project panel and call it _Render in which I place all the composition I intend to render. this can help me reduce the chance I accidentally render the wrong composition.

                         

                        one final note: please don't crop screenshots ever again. we need to see the full information - this could potentially save all of us some time investigation the root of this problem. for example, we could see the final movie is called "Main Graph" while the composition you are in is called "Main Composition".

                        • 9. Re: The exported audio visualisation project looks different to the AE project.
                          ianj49859707 Level 1

                          I have been rendering "Main Composition" each time. So that won't be the problem.

                           

                          I'll make sure I don't crop screenshots next time.

                           

                          Thank you for your help anyway.

                          • 10. Re: The exported audio visualisation project looks different to the AE project.
                            Roei Tzoref Adobe Community Professional

                            I have been rendering "Main Composition" each time. So that won't be the problem.

                            I won't quit on you yet, please upload your project file here so we can examine your project and the render queue.

                            • 11. Re: The exported audio visualisation project looks different to the AE project.
                              ianj49859707 Level 1

                              I've decided to go in a different direction because of running out of time. Thank you for your help though.