1 Reply Latest reply on Jan 26, 2017 5:11 AM by kglad

    Navigate Buttons not working after GoToAndPlay/Stop

    kaymedelynn

      I tried using both functions of GoToAndPlay and GoToAndStop. The full picture is this:

      I have a table of contents, and on that you can click a button and it will go to and either stop/play the designated frame. I tested both and get the same result of being stranded on that frame. However, the button that navigates me there works fine.

      That's all fine and dandy, until I want to use the navigation arrows on the bottom or top. I'm stuck on that frame that I was directed to, and none of the buttons on that frame will work at all.

      Please help?

        • 1. Re: Navigate Buttons not working after GoToAndPlay/Stop
          kglad Adobe Community Professional & MVP

          after going to a frame your problematic buttons probably fail to exist at some point.  if you think they still exist (because you think you seem them), then they are not the same buttons as the one's that were on stage when the button listener code was defined.

           

          the easiest way to fix that is to create a button in the keyframe where you have your code and make sure it works.  then put it in a layer with frames that extend to the end of the timeline.  you can add keyframes after that first one and change the button's appearance (eg, make it not visible) but don't remove it.